summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-05 11:27:55 -0800
committerMatt Turner <mattst88@gentoo.org>2022-03-05 11:28:16 -0800
commitc74c3dcad7e410297a321e78f934da2347ec5691 (patch)
tree1b47588de9d6ae3f1f29946894be2294c6cc888c /gnome-extra/gnome-tweaks
parentapp-containers/podman: Bump to version 4.0.2 (diff)
downloadgentoo-c74c3dcad7e410297a321e78f934da2347ec5691.tar.gz
gentoo-c74c3dcad7e410297a321e78f934da2347ec5691.tar.bz2
gentoo-c74c3dcad7e410297a321e78f934da2347ec5691.zip
gnome-extra/gnome-tweaks: Version bump to 40.10
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-tweaks')
-rw-r--r--gnome-extra/gnome-tweaks/Manifest1
-rw-r--r--gnome-extra/gnome-tweaks/gnome-tweaks-40.10.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/gnome-extra/gnome-tweaks/Manifest b/gnome-extra/gnome-tweaks/Manifest
index 02cffd140f22..c70576574a6d 100644
--- a/gnome-extra/gnome-tweaks/Manifest
+++ b/gnome-extra/gnome-tweaks/Manifest
@@ -1 +1,2 @@
DIST gnome-tweaks-40.0.tar.xz 251908 BLAKE2B 4280e7565da3f95d7bcd81ba874d2f15e8c3834ab052cb4cf7cde8060eaea016670acf6f441d2cbce4b7566ba0bb7a7f9666b257893bc7b22b1cdc4d5a0edee2 SHA512 c3467f40af6bb79c2b10cb429e93aa29261066c2a5fd744bf2801c4e596cc270d45302ebfa942ee0c40067849c12e1ccd404c40e7f594bcff4c44cfe3f90bb97
+DIST gnome-tweaks-40.10.tar.xz 251712 BLAKE2B 7e9e04b86ffcff25cafd2a6dfc0c7be14c8caa4ae003369c34ed2c40c36ce857b05de9994f7c2187cbdd535f464b92f782ec91b835318c2b5d2219ad817fbe56 SHA512 1247933ad2f93bd7817af367d715468591840df4840d45641033ca19ea26c64239828ba3e24fafb8694014a98024b911266c314172ba8e37d6c4165e7e6e8a29
diff --git a/gnome-extra/gnome-tweaks/gnome-tweaks-40.10.ebuild b/gnome-extra/gnome-tweaks/gnome-tweaks-40.10.ebuild
new file mode 100644
index 000000000000..30feae50500c
--- /dev/null
+++ b/gnome-extra/gnome-tweaks/gnome-tweaks-40.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Customize advanced GNOME options"
+HOMEPAGE="https://wiki.gnome.org/Apps/Tweaks"
+
+LICENSE="GPL-3+ CC0-1.0"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="${PYTHON_DEPS}"
+# See README.md for list of deps
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.10.2:3[${PYTHON_USEDEP}]
+ ')
+ >=gnome-base/gnome-settings-daemon-3
+ x11-themes/sound-theme-freedesktop
+
+ >=dev-libs/glib-2.58:2
+ >=x11-libs/gtk+-3.12:3[introspection]
+ >=gnome-base/gnome-desktop-3.30:3[introspection]
+ gui-libs/libhandy:1[introspection]
+ net-libs/libsoup:2.4[introspection]
+ x11-libs/libnotify[introspection]
+
+ >=gnome-base/gsettings-desktop-schemas-40.0
+ >=gnome-base/gnome-shell-3.24
+ x11-wm/mutter
+"
+BDEPEND=">=sys-devel/gettext-0.19.8"
+
+PATCHES=(
+ "${FILESDIR}"/3.28.1-gentoo-cursor-themes.patch # Add contents of Gentoo's cursor theme directory to cursor theme list
+)
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}"/usr/bin/
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}