summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-01-29 11:32:25 +0100
committerPacho Ramos <pacho@gentoo.org>2022-01-29 11:42:45 +0100
commitfd8b30464d660cfab023919cecf5b247bd63cd3b (patch)
tree21e741f3ffec6db458e4be865cedaa9dfbf28a82 /gnome-extra/gnome-shell-extension-weather-in-the-clock
parentgnome-extra/gnome-shell-extension-alphabetical-grid: add gnome-shell-extensio... (diff)
downloadgentoo-fd8b30464d660cfab023919cecf5b247bd63cd3b.tar.gz
gentoo-fd8b30464d660cfab023919cecf5b247bd63cd3b.tar.bz2
gentoo-fd8b30464d660cfab023919cecf5b247bd63cd3b.zip
gnome-extra/gnome-shell-extension-weather-in-the-clock: New extension
Simply shows gnome-weather information in the panel without relying on external tools Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-weather-in-the-clock')
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20211108.ebuild49
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/metadata.xml8
3 files changed, 58 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest b/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest
new file mode 100644
index 000000000000..f1ca49884f6c
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest
@@ -0,0 +1 @@
+DIST gnome-shell-extension-weather-in-the-clock-20211108.tar.gz 127000 BLAKE2B 9c884b7bf093ef29fcd1cf3aa58accb4d5f70fa38bf9bd0cc0cfb81564952de9c6b9f1dbead26dd3902cc09d3be42f30c8e813a8fecb33c3753f45abe833974e SHA512 bb16b470f9d0d7fdcd90d5ec4a2723a97d808d8341c816aacd973390201c5e63a71aec51efc9953903a70ad964e406a104b9029c3c08b25b7a333de3e673dd6e
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20211108.ebuild b/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20211108.ebuild
new file mode 100644
index 000000000000..1d7cf088c5ac
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20211108.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Display the current weather in the clock"
+HOMEPAGE="https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock"
+COMMIT="b36cc55bf41af1a4c801ddeb0fd71d1294892c4c"
+SRC_URI="https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.38
+ gnome-extra/gnome-weather
+"
+DEPEND=""
+BDEPEND=""
+
+extension_uuid="weatherintheclock@JasonLG1979.github.io"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/gnome-shell/extensions/
+ doins -r "${extension_uuid}"
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/metadata.xml b/gnome-extra/gnome-shell-extension-weather-in-the-clock/metadata.xml
new file mode 100644
index 000000000000..3947e1bf6d57
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+</pkgmetadata>