summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-10-02 11:02:47 +0200
committerPacho Ramos <pacho@gentoo.org>2022-10-02 11:55:00 +0200
commitf24231114a5a2c1e6ced47a813e99fe2871f1cfd (patch)
treee36ec94e43cce898ace3d9dc86973c4590d30efc /gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-46.ebuild
parentgnome-extra/gnome-shell-extension-dash-to-panel: add 52 (diff)
downloadgentoo-f24231114a5a2c1e6ced47a813e99fe2871f1cfd.tar.gz
gentoo-f24231114a5a2c1e6ced47a813e99fe2871f1cfd.tar.bz2
gentoo-f24231114a5a2c1e6ced47a813e99fe2871f1cfd.zip
gnome-extra/gnome-shell-extension-appindicator: add 46
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-46.ebuild')
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-46.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-46.ebuild b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-46.ebuild
new file mode 100644
index 000000000000..e8439a3ef588
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-46.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson
+
+DESCRIPTION="Support Ubuntu AppIndicators and KStatusNotifierItems in Gnome"
+HOMEPAGE="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+SRC_URI="https://github.com/ubuntu/gnome-shell-extension-appindicator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ dev-libs/libappindicator:3
+ >=gnome-base/gnome-shell-3.34
+"
+BDEPEND="
+ app-misc/jq
+"
+
+src_install() {
+ meson_src_install
+ rm "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}