summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/gwp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/gwp')
-rw-r--r--games-strategy/gwp/Manifest1
-rw-r--r--games-strategy/gwp/files/gwp-0.4.0-exec-stack.patch89
-rw-r--r--games-strategy/gwp/files/gwp-0.4.0-gcc41.patch107
-rw-r--r--games-strategy/gwp/gwp-0.4.0-r3.ebuild61
-rw-r--r--games-strategy/gwp/metadata.xml5
5 files changed, 263 insertions, 0 deletions
diff --git a/games-strategy/gwp/Manifest b/games-strategy/gwp/Manifest
new file mode 100644
index 000000000000..1cf46e02ec93
--- /dev/null
+++ b/games-strategy/gwp/Manifest
@@ -0,0 +1 @@
+DIST gwp-0.4.0.tar.gz 2294453 SHA256 e2734e019e2c3ef28cb0abd524c193ec5beb35d2bc8ba3e10652fac45c8bbe99 SHA512 dcb23bb49929bc01129ab5f02b56edb7f775feb0c37bd7613277af8aa0f4b47667f95413725f74a2b83b60159555a50fcabdc8736094aad0684b03cd150b4957 WHIRLPOOL 4c3cc223799132bf2021e1cb2bc10c88ecd41f3ec7191aaf2c115b91985bfd0717ce70f476234bc64f52286c19ba6a9b9e3722f4d81cf2b91ce9c0b1579b9cd9
diff --git a/games-strategy/gwp/files/gwp-0.4.0-exec-stack.patch b/games-strategy/gwp/files/gwp-0.4.0-exec-stack.patch
new file mode 100644
index 000000000000..1458b7ba1dfd
--- /dev/null
+++ b/games-strategy/gwp/files/gwp-0.4.0-exec-stack.patch
@@ -0,0 +1,89 @@
+--- src/starchart.c
++++ src/starchart.c
+@@ -3187,10 +3187,16 @@
+ /**
+ * Initializes starchart constellations.
+ */
++static GSList *planets;
++
++static void add_item (gpointer key, gpointer value, gpointer user_data) {
++ /* GSList *p_list = (GSList *)user_data; */
++ planets = g_slist_append (planets, value);
++}
++
+ static void
+ init_starchart_constellations (void)
+ {
+- GSList *planets = NULL;
+ GSList *ppq[TOTAL_QUADS];
+ GSList *list_nearby = NULL;
+ GwpPlanet *planet_a, *planet_b;
+@@ -3199,10 +3205,6 @@
+ gdouble wx, wy;
+ gdouble ax, ay, bx, by, zoom;
+
+- static void add_item (gpointer key, gpointer value, gpointer user_data) {
+- /* GSList *p_list = (GSList *)user_data; */
+- planets = g_slist_append (planets, value);
+- }
+
+ g_hash_table_foreach (planet_list, (GHFunc)add_item, NULL);
+
+--- src/vcr.c
++++ src/vcr.c
+@@ -2687,12 +2687,29 @@
+ return( retval );
+ }
+
++static gchar *name;
++
++static void foreach_func( gpointer key, gpointer value, gpointer user_data )
++{
++ GwpShip *ship = GWP_SHIP( value );
++ GtkComboBox *box = GTK_COMBO_BOX( lookup_widget( "vcr_comboboxentry_sel_ext_shp_a" ) );
++ gint *idlist = (gint *)g_object_get_data(G_OBJECT(lookup_widget("vcr_comboboxentry_sel_ext_shp_a")), "shipidlist");
++ gint curr = idlist[0];
++
++ if( gwp_ship_is_mine( ship ) )
++ {
++ curr++;
++ idlist[curr] = gwp_object_get_id( GWP_OBJECT(ship) );
++ idlist[0]++;
++ g_sprintf( name, "%03d: ", idlist[curr] );
++ strncat( name, gwp_object_get_name (GWP_OBJECT(ship)), 50 );
++ gtk_combo_box_append_text( box, name );
++ }
++}
+
+ void vcr_populate_ship_a_list( GtkWidget *widget, gpointer user_data )
+ {
+- gchar *name;
+ gint *idlist;
+- static void foreach_func( gpointer key, gpointer value, gpointer user_data );
+
+ /* test if list is already populated */
+ idlist = (gint *)g_object_get_data(G_OBJECT(lookup_widget("vcr_comboboxentry_sel_ext_shp_a")), "shipidlist");
+@@ -2708,23 +2725,7 @@
+ GtkWidget *combox = lookup_widget("vcr_comboboxentry_sel_ext_shp_a");
+ g_object_set_data(G_OBJECT(combox), "shipidlist", idlist );
+
+- void foreach_func( gpointer key, gpointer value, gpointer user_data )
+- {
+- GwpShip *ship = GWP_SHIP( value );
+- GtkComboBox *box = GTK_COMBO_BOX( lookup_widget( "vcr_comboboxentry_sel_ext_shp_a" ) );
+- gint *idlist = (gint *)g_object_get_data(G_OBJECT(lookup_widget("vcr_comboboxentry_sel_ext_shp_a")), "shipidlist");
+- gint curr = idlist[0];
+
+- if( gwp_ship_is_mine( ship ) )
+- {
+- curr++;
+- idlist[curr] = gwp_object_get_id( GWP_OBJECT(ship) );
+- idlist[0]++;
+- g_sprintf( name, "%03d: ", idlist[curr] );
+- strncat( name, gwp_object_get_name (GWP_OBJECT(ship)), 50 );
+- gtk_combo_box_append_text( box, name );
+- }
+- }
+
+ g_hash_table_foreach( ship_list, (GHFunc) foreach_func, user_data );
+
diff --git a/games-strategy/gwp/files/gwp-0.4.0-gcc41.patch b/games-strategy/gwp/files/gwp-0.4.0-gcc41.patch
new file mode 100644
index 000000000000..fa7ee5c5443c
--- /dev/null
+++ b/games-strategy/gwp/files/gwp-0.4.0-gcc41.patch
@@ -0,0 +1,107 @@
+--- src/gwp-game-state.c.old 2006-03-05 00:56:48.000000000 +0900
++++ src/gwp-game-state.c 2006-03-05 00:57:38.000000000 +0900
+@@ -749,7 +749,7 @@
+ /* Connect to interesting signals */
+ /**********************************/
+ /* Selected planets */
+- static void planet_conn (gpointer key, gpointer value, gpointer self) {
++ void planet_conn (gpointer key, gpointer value, gpointer self) {
+ g_signal_connect (GWP_PLANET(value),
+ "selected",
+ G_CALLBACK(selected_planet_notification),
+@@ -757,7 +757,7 @@
+ }
+ g_hash_table_foreach (planet_list, (GHFunc) planet_conn, self);
+ /* Selected ships */
+- static void ship_conn (gpointer key, gpointer value, gpointer self) {
++ void ship_conn (gpointer key, gpointer value, gpointer self) {
+ g_signal_connect (GWP_SHIP(value),
+ "selected",
+ G_CALLBACK(selected_ship_notification),
+--- src/starchart.c.old 2006-03-05 01:13:39.000000000 +0900
++++ src/starchart.c 2006-03-05 01:18:04.000000000 +0900
+@@ -2111,7 +2111,7 @@
+ /*******************/
+ /* Planets signals */
+ /*******************/
+- static void planet_conn (gpointer key, gpointer value, gpointer data) {
++ void planet_conn (gpointer key, gpointer value, gpointer data) {
+ g_signal_connect (GWP_PLANET(value),
+ "property-changed",
+ G_CALLBACK(update_planet_notification),
+--- src/vp_utils.c.old 2006-03-05 01:18:14.000000000 +0900
++++ src/vp_utils.c 2006-03-05 01:18:52.000000000 +0900
+@@ -2590,7 +2590,7 @@
+ gwp_planet_set_colonists (planet, atoi(p_clans));
+
+ /* Compare func */
+- static gint compare_race (gconstpointer race, gconstpointer adj) {
++ gint compare_race (gconstpointer race, gconstpointer adj) {
+ gchar *race_str = gwp_race_get_adjective(GWP_RACE(race));
+ if (strncmp(race_str, adj, strlen(adj)) == 0)
+ return 0;
+@@ -2639,7 +2639,7 @@
+ /* Assign known planet values */
+ gwp_planet_set_is_known (planet, TRUE);
+ /* Compare func */
+- static gint compare_race (gconstpointer race, gconstpointer adj) {
++ gint compare_race (gconstpointer race, gconstpointer adj) {
+ gchar *race_str = gwp_race_get_adjective(GWP_RACE(race));
+ if (strncmp(race_str, adj, strlen(adj)) == 0)
+ return 0;
+--- src/gwp-py-mappings.c.old 2006-03-05 01:28:39.000000000 +0900
++++ src/gwp-py-mappings.c 2006-03-05 01:29:30.000000000 +0900
+@@ -8657,7 +8657,7 @@
+ {
+ PyObject *ret = PyDict_New();
+
+- static void add_ship (gpointer key, gpointer value, gpointer user_data) {
++ void add_ship (gpointer key, gpointer value, gpointer user_data) {
+ PyObject *dict = (PyObject *)user_data;
+ GwpShip *ship = GWP_SHIP(value);
+
+@@ -8679,7 +8679,7 @@
+ {
+ PyObject *ret = PyDict_New();
+
+- static void add_planet (gpointer key, gpointer value, gpointer user_data) {
++ void add_planet (gpointer key, gpointer value, gpointer user_data) {
+ PyObject *dict = (PyObject *)user_data;
+ GwpPlanet *planet = GWP_PLANET(value);
+
+@@ -8701,7 +8701,7 @@
+ {
+ PyObject *ret = PyDict_New();
+
+- static void add_hullspec (gpointer value, gpointer user_data) {
++ void add_hullspec (gpointer value, gpointer user_data) {
+ PyObject *dict = (PyObject *)user_data;
+ GwpHullSpec *hullspec = GWP_HULLSPEC(value);
+
+@@ -8723,7 +8723,7 @@
+ {
+ PyObject *ret = PyDict_New();
+
+- static void add_engspec (gpointer value, gpointer user_data) {
++ void add_engspec (gpointer value, gpointer user_data) {
+ PyObject *dict = (PyObject *)user_data;
+ GwpEngSpec *engspec = GWP_ENGSPEC(value);
+
+@@ -8745,7 +8745,7 @@
+ {
+ PyObject *ret = PyDict_New();
+
+- static void add_beamspec (gpointer value, gpointer user_data) {
++ void add_beamspec (gpointer value, gpointer user_data) {
+ PyObject *dict = (PyObject *)user_data;
+ GwpBeamSpec *beamspec = GWP_BEAMSPEC(value);
+
+@@ -8767,7 +8767,7 @@
+ {
+ PyObject *ret = PyDict_New();
+
+- static void add_torpspec (gpointer value, gpointer user_data) {
++ void add_torpspec (gpointer value, gpointer user_data) {
+ PyObject *dict = (PyObject *)user_data;
+ GwpTorpSpec *torpspec = GWP_TORPSPEC(value);
+
diff --git a/games-strategy/gwp/gwp-0.4.0-r3.ebuild b/games-strategy/gwp/gwp-0.4.0-r3.ebuild
new file mode 100644
index 000000000000..1b2c6f3fad10
--- /dev/null
+++ b/games-strategy/gwp/gwp-0.4.0-r3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils flag-o-matic gnome2 python-single-r1
+
+DESCRIPTION="GNOME client for the classic PBEM strategy game VGA Planets 3"
+HOMEPAGE="http://gwp.lunix.com.ar/"
+SRC_URI="http://gwp.lunix.com.ar/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls opengl python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="x11-libs/gtk+:2
+ gnome-base/libgnomeui
+ gnome-base/libglade
+ app-text/rarian
+ dev-libs/libpcre
+ nls? ( virtual/libintl )
+ opengl? ( x11-libs/gtkglext )
+ python? ( ${PYTHON_DEPS}
+ dev-python/pygtk[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ append-libs -lm
+ epatch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-exec-stack.patch
+ sed -i \
+ -e '/ -O1/d' \
+ -e '/ -g$/d' \
+ src/Makefile.in || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable nls) \
+ $(use_enable opengl gtkglext) \
+ $(use_enable python)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog CHANGES README TODO" \
+ gnome2_src_install
+ rm -rf "${D}"/usr/share/doc/gwp
+}
diff --git a/games-strategy/gwp/metadata.xml b/games-strategy/gwp/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/gwp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>