summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-04-18 20:07:40 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-04-18 21:31:45 +0200
commitf7864f5584e5a1df9bcdf7f0d044c72d7866226a (patch)
tree2112aa50e6cac094c8736090c23cec70f859e455 /games-simulation
parentgames-emulation/ppsspp: remove unused patches (diff)
downloadgentoo-f7864f5584e5a1df9bcdf7f0d044c72d7866226a.tar.gz
gentoo-f7864f5584e5a1df9bcdf7f0d044c72d7866226a.tar.bz2
gentoo-f7864f5584e5a1df9bcdf7f0d044c72d7866226a.zip
games-simulation/openrct2: remove unused patch
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openrct2/files/openrct2-0.4.7-musl.patch55
1 files changed, 0 insertions, 55 deletions
diff --git a/games-simulation/openrct2/files/openrct2-0.4.7-musl.patch b/games-simulation/openrct2/files/openrct2-0.4.7-musl.patch
deleted file mode 100644
index 1096bc018ff2..000000000000
--- a/games-simulation/openrct2/files/openrct2-0.4.7-musl.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 010c19ba61a3180dab6350aadc578414ad0c0051 Mon Sep 17 00:00:00 2001
-From: Conrad Kostecki <conikost@gentoo.org>
-Date: Mon, 1 Jan 2024 20:34:19 +0100
-Subject: [PATCH 1/2] src/openrct2/core/FileStream.cpp: drop ftello64, fseeko64
-
-The static usage definition of ftello64 and friends is not correct.
-While this currently works on glibc, this breaks on musl, as musl
-already is LFS aware. The solution is to drop this and add instead
-'-D_FILE_OFFSET_BITS=64' to the build system.
-
-Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
----
- src/openrct2/core/FileStream.cpp | 5 -----
- 1 file changed, 5 deletions(-)
-
-diff --git a/src/openrct2/core/FileStream.cpp b/src/openrct2/core/FileStream.cpp
-index 90a7f7a366cc..6fd7b7b1b42c 100644
---- a/src/openrct2/core/FileStream.cpp
-+++ b/src/openrct2/core/FileStream.cpp
-@@ -21,11 +21,6 @@
- # include <io.h>
- #endif
-
--#if defined(__linux__) && !defined(__ANDROID__)
--# define ftello ftello64
--# define fseeko fseeko64
--#endif
--
- #ifdef _MSC_VER
- # define ftello _ftelli64
- # define fseeko _fseeki64
-
-From 7c638c786527a26a3e83d155ca8ff4d55f01347f Mon Sep 17 00:00:00 2001
-From: Conrad Kostecki <conikost@gentoo.org>
-Date: Mon, 1 Jan 2024 20:23:24 +0100
-Subject: [PATCH 2/2] CMakeLists.txt: add D_FILE_OFFSET_BITS=64
-
-Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
----
- src/openrct2/CMakeLists.txt | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/openrct2/CMakeLists.txt b/src/openrct2/CMakeLists.txt
-index 367939c9622c..55882a1097d3 100644
---- a/src/openrct2/CMakeLists.txt
-+++ b/src/openrct2/CMakeLists.txt
-@@ -265,3 +265,7 @@ else ()
- # Dummy target to ease invocation
- add_custom_target(${PROJECT_NAME}-headers-check)
- endif ()
-+
-+if (UNIX)
-+ add_definitions(-D_FILE_OFFSET_BITS=64)
-+endif ()