summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-17 01:17:30 +0100
committerSam James <sam@gentoo.org>2024-04-17 01:18:00 +0100
commitf274e3e6733ff211d1e2454c622cc49403f159bb (patch)
tree74dde3bcb6e67de0bab78b195fbc5ca951bb2384 /games-rpg
parentdev-qt/qtwebengine: fix webdriver build under some configurations (diff)
downloadgentoo-f274e3e6733ff211d1e2454c622cc49403f159bb.tar.gz
gentoo-f274e3e6733ff211d1e2454c622cc49403f159bb.tar.bz2
gentoo-f274e3e6733ff211d1e2454c622cc49403f159bb.zip
games-rpg/freedroidrpg: drop unnecessary macro from configure.ac
Closes: https://bugs.gentoo.org/921033 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/freedroidrpg/files/freedroidrpg-1.0-AC_INCLUDES_DEFAULT.patch13
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-1.0.ebuild16
2 files changed, 25 insertions, 4 deletions
diff --git a/games-rpg/freedroidrpg/files/freedroidrpg-1.0-AC_INCLUDES_DEFAULT.patch b/games-rpg/freedroidrpg/files/freedroidrpg-1.0-AC_INCLUDES_DEFAULT.patch
new file mode 100644
index 000000000000..db9754c7e4c6
--- /dev/null
+++ b/games-rpg/freedroidrpg/files/freedroidrpg-1.0-AC_INCLUDES_DEFAULT.patch
@@ -0,0 +1,13 @@
+AC_INCLUDES_DEFAULT isn't actually needed and it causes a QA warning.
+
+https://bugs.gentoo.org/921033
+--- a/configure.ac
++++ b/configure.ac
+@@ -402,7 +402,6 @@ dnl Checks for typedefs, structures, and compiler characteristics.
+ SILENT_BOX([Checking types])
+
+ AC_HEADER_DIRENT
+-AC_INCLUDES_DEFAULT
+ AC_PROG_EGREP
+
+ AC_CHECK_HEADERS_ONCE([sys/time.h])
diff --git a/games-rpg/freedroidrpg/freedroidrpg-1.0.ebuild b/games-rpg/freedroidrpg/freedroidrpg-1.0.ebuild
index 01d5f7f78f03..11cf4a0857d7 100644
--- a/games-rpg/freedroidrpg/freedroidrpg-1.0.ebuild
+++ b/games-rpg/freedroidrpg/freedroidrpg-1.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
LUA_COMPAT=( lua5-3 )
PYTHON_COMPAT=( python3_{9..11} )
-inherit lua-single python-any-r1 xdg
+inherit autotools lua-single python-any-r1 xdg
DESCRIPTION="Modification of the classical Freedroid engine into an RPG"
HOMEPAGE="https://www.freedroid.org/"
@@ -30,13 +30,19 @@ RDEPEND="
media-libs/glew:0=
media-libs/libglvnd[X]
)
- sound? ( media-libs/sdl-mixer[vorbis] )"
+ sound? ( media-libs/sdl-mixer[vorbis] )
+"
DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
sys-devel/gettext
app-alternatives/awk
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-AC_INCLUDES_DEFAULT.patch
+)
pkg_setup() {
lua-single_pkg_setup
@@ -46,6 +52,8 @@ pkg_setup() {
src_prepare() {
default
+ eautoreconf
+
python_fix_shebang src/gen_savestruct.py
rm data/sound/speak.py || die # unused, skip install + python rdep
}