summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/freedroidrpg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/freedroidrpg')
-rw-r--r--games-rpg/freedroidrpg/Manifest1
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-0.15.1.ebuild69
-rw-r--r--games-rpg/freedroidrpg/metadata.xml51
3 files changed, 121 insertions, 0 deletions
diff --git a/games-rpg/freedroidrpg/Manifest b/games-rpg/freedroidrpg/Manifest
new file mode 100644
index 000000000000..d37f49a2a359
--- /dev/null
+++ b/games-rpg/freedroidrpg/Manifest
@@ -0,0 +1 @@
+DIST freedroidRPG-0.15.1.tar.gz 209427247 SHA256 3e0e0e901f05386f49b8dfa1a8b3582ea82347deb7fb8e94fc15bf8ad058ba08 SHA512 3e38753a040e507229b87235e449fc77db2457a4eb0129f8866a58e3863baa08304feb846828be95183a0b9e46f11761c706571ea68500203c953e1467e108a4 WHIRLPOOL 42f0d6e5ae48437ad0fb00d38966904601de80f2d7dbf6d93d40da5cf4897cc12fc82ec1b9ce500947ed4f1f583eb736fbfc2cdf7619f22999c0e28a007b0aac
diff --git a/games-rpg/freedroidrpg/freedroidrpg-0.15.1.ebuild b/games-rpg/freedroidrpg/freedroidrpg-0.15.1.ebuild
new file mode 100644
index 000000000000..0d8c99541907
--- /dev/null
+++ b/games-rpg/freedroidrpg/freedroidrpg-0.15.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils gnome2-utils python-any-r1 games
+
+DESCRIPTION="A modification of the classical Freedroid engine into an RPG"
+HOMEPAGE="http://freedroid.sourceforge.net/"
+SRC_URI="mirror://sourceforge/freedroid/freedroidRPG-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="opengl vorbis"
+
+RDEPEND="media-libs/libsdl[opengl?,video]
+ dev-lang/lua
+ virtual/jpeg
+ media-libs/libpng:0
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[vorbis?]
+ >=media-libs/sdl-gfx-2.0.21
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ x11-libs/libX11
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ # No need for executable game resources
+ find sound graphics -type f -execdir chmod -c a-x '{}' +
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-fastmath \
+ $(use_enable opengl) \
+ $(use_enable vorbis)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ rm -f "${D}/${GAMES_BINDIR}/"{croppy,pngtoico,*glue*,explode*,make_atlas}
+ newicon -s 64 win32/w32icon2_64x64.png ${PN}.png
+ make_desktop_entry freedroidRPG "Freedroid RPG"
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-rpg/freedroidrpg/metadata.xml b/games-rpg/freedroidrpg/metadata.xml
new file mode 100644
index 000000000000..145798144713
--- /dev/null
+++ b/games-rpg/freedroidrpg/metadata.xml
@@ -0,0 +1,51 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription>
+Hello, and welcome to the Freedroid page.
+
+THE CLASSICAL FREEDROID: Freedroid is a clone of the classic game
+"Paradroid" on Commodore 64 with some improvements and extensions to
+the classic version.
+
+In this game, you control a robot, depicted by a small white ball with
+a few numbers within an interstellar spaceship consisting of several
+decks connected by elevators.
+
+The aim of the game is to destroy all enemy robots, depicted by small
+black balls with a few numbers, by either shooting them or seizing
+control over them by creating connections in a short subgame of
+electric circuits.
+
+Development of this game is now complete. The final version came out
+in august 2003 and runs on Linux, Mac OSX, Sharp Zaurus and even that
+strange Windows wannabe of an operating system. Thanks to all who
+helped.
+Minor fixes and maintainance will of course still continue though...
+
+FREEDROID RPG: The Freedroid RPG is an extension/modification of the
+classical freedroid engine into an RPG. The main differences to the
+classical version are as follows:
+* The Tux is the main character of the rpg. He is not displayed as a
+ ball like in Freedroid but rather as an animated character, while
+ other droids and humans in the game are still represented as the balls
+ with some number or code in them.
+* Dialogs and chatting with friendly droids and humans:
+ Multiple-choice menus and voice samples (with subtitles for those
+ without sound).
+* Melee weapons, armour and other items to be equipped have been
+ added.
+* An automap feature was added.
+* Saving and loading of games.
+* A shop to trade things.
+* Controls are different: Mouse can be used to do everything.
+ Joystick is not supported for moving around any more.
+* The archive size (including sound samples) is about 10 times as big
+ as for the classical version. I'd like to appologize to all 56K modem
+ owners at this point.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">freedroid</remote-id>
+ </upstream>
+</pkgmetadata>