summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-02-23 10:41:37 +0000
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-23 18:40:07 +0100
commit3628e45fed8f446c61d595c575293759c97e8cc3 (patch)
tree25eb876749b54bed0229b3a521cc738a9d20778d /games-puzzle/nudoku
parentmedia-gfx/freecad: fixed dying in install phase in live ebuild when tests are... (diff)
downloadgentoo-3628e45fed8f446c61d595c575293759c97e8cc3.tar.gz
gentoo-3628e45fed8f446c61d595c575293759c97e8cc3.tar.bz2
gentoo-3628e45fed8f446c61d595c575293759c97e8cc3.zip
games-puzzle/nudoku: add patch to include locale.h
Closes: https://bugs.gentoo.org/895990 Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/29743 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-puzzle/nudoku')
-rw-r--r--games-puzzle/nudoku/files/nudoku-2.1.0-include-locale.patch22
-rw-r--r--games-puzzle/nudoku/nudoku-2.1.0.ebuild3
2 files changed, 24 insertions, 1 deletions
diff --git a/games-puzzle/nudoku/files/nudoku-2.1.0-include-locale.patch b/games-puzzle/nudoku/files/nudoku-2.1.0-include-locale.patch
new file mode 100644
index 000000000000..d4d1c89bd104
--- /dev/null
+++ b/games-puzzle/nudoku/files/nudoku-2.1.0-include-locale.patch
@@ -0,0 +1,22 @@
+From ffe61c8cb6dcf6032960fa75ac2b66b5f1906e37 Mon Sep 17 00:00:00 2001
+From: Michael Vetter <jubalh@iodoru.org>
+Date: Thu, 23 Feb 2023 10:58:43 +0100
+Subject: [PATCH] Include locale.h
+
+See https://bugs.gentoo.org/895990
+---
+ src/main.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/main.c b/src/main.c
+index 74d6a0e..77a0a03 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -25,6 +25,7 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
+ #include <ncurses.h> /* ncurses */
+ #include <time.h> /* time */
+ #include <string.h> /* strcmp, strlen */
++#include <locale.h> /* setlocale */
+ #include "sudoku.h" /* sudoku functions */
+ #ifdef ENABLE_CAIRO
+ #include "outp.h" /* output functions */
diff --git a/games-puzzle/nudoku/nudoku-2.1.0.ebuild b/games-puzzle/nudoku/nudoku-2.1.0.ebuild
index 9bd564dfc76a..f4a69b9fc4c7 100644
--- a/games-puzzle/nudoku/nudoku-2.1.0.ebuild
+++ b/games-puzzle/nudoku/nudoku-2.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,6 +25,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-2.1.0-ncurses-link.patch"
+ "${FILESDIR}/${PN}-2.1.0-include-locale.patch"
)
src_prepare() {