summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/mures
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/mures')
-rw-r--r--games-puzzle/mures/Manifest1
-rw-r--r--games-puzzle/mures/files/mures-0.5-save.patch33
-rw-r--r--games-puzzle/mures/files/mures-0.5-underlink.patch13
-rw-r--r--games-puzzle/mures/metadata.xml8
-rw-r--r--games-puzzle/mures/mures-0.5.ebuild87
5 files changed, 142 insertions, 0 deletions
diff --git a/games-puzzle/mures/Manifest b/games-puzzle/mures/Manifest
new file mode 100644
index 000000000000..50534d8e59ca
--- /dev/null
+++ b/games-puzzle/mures/Manifest
@@ -0,0 +1 @@
+DIST mures-0.5.tar.gz 638528 SHA256 84da71b52b6fc16587fae776f0ede1cf20ab08ea2f3ce1aaa220ed187cd757e2 SHA512 907b22adffcc0457d866da27bd11d61663c6a1eed1c0aa4b437f8e341065df86f2ab06851619e2fa4088aa0b2becaf9376bad693c83345f8d1ee862c31740eff WHIRLPOOL 6cf0cf6fe3ce2c8919a1ed719c9e05fbd89a7331d78670880b079b4fc6311cc6a56986c0cf73295b23ca443f4cfba162495fce1e11f10bc47ad2f5d421e1e655
diff --git a/games-puzzle/mures/files/mures-0.5-save.patch b/games-puzzle/mures/files/mures-0.5-save.patch
new file mode 100644
index 000000000000..704dcf1f53bc
--- /dev/null
+++ b/games-puzzle/mures/files/mures-0.5-save.patch
@@ -0,0 +1,33 @@
+--- gi_sdl.c
++++ gi_sdl.c
+@@ -606,6 +606,7 @@
+ {
+ int i,found;
+ gi_sdl_data *data = &GI;
++ char temp_path[70];
+
+ switch(e.type) {
+
+@@ -714,7 +715,8 @@
+ sim_start(&g->sim);
+ break;
+ case SDLK_F6:
+- map_save(&g->sim.map, "saved.mus");
++ snprintf(temp_path, 70, "%s/.mures.save", getenv("HOME"));
++ map_save(&g->sim.map, temp_path);
+ break;
+ case SDLK_F1:
+ game_restart(g);
+
+--- output.c
++++ output.c
+@@ -215,7 +215,8 @@
+
+ void output_screenshot()
+ {
+- char *l = "shot.bmp";
++ char l[70];
++ snprintf(l, 70, "%s/mures_shot.bmp", getenv("HOME"));
+ SDL_SaveBMP(screen, l);
+ printf("Screenshot saved to %s.\n", l);
+ }
diff --git a/games-puzzle/mures/files/mures-0.5-underlink.patch b/games-puzzle/mures/files/mures-0.5-underlink.patch
new file mode 100644
index 000000000000..805cd0c7b35d
--- /dev/null
+++ b/games-puzzle/mures/files/mures-0.5-underlink.patch
@@ -0,0 +1,13 @@
+--- src/Makefile.am.old 2011-06-21 14:39:14.404333493 +0200
++++ src/Makefile.am 2011-06-21 14:39:30.538340283 +0200
+@@ -1,8 +1,8 @@
+ bin_PROGRAMS = mures
+
+ mures_LDADD = \
+- -llua -L./lua
+- $(STATIC_LIBS)
++ -llua -L./lua \
++ $(STATIC_LIBS) -lm
+
+ SUBDIRS = lua gui images maps sounds textures
+
diff --git a/games-puzzle/mures/metadata.xml b/games-puzzle/mures/metadata.xml
new file mode 100644
index 000000000000..6b7ddc83ba9b
--- /dev/null
+++ b/games-puzzle/mures/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">mures</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-puzzle/mures/mures-0.5.ebuild b/games-puzzle/mures/mures-0.5.ebuild
new file mode 100644
index 000000000000..3831ba20ece0
--- /dev/null
+++ b/games-puzzle/mures/mures-0.5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit autotools eutils games
+
+DESCRIPTION="A clone of Sega's Chu Chu Rocket"
+HOMEPAGE="http://mures.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mures/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ opengl? ( virtual/opengl )"
+RDEPEND="${DEPEND}"
+
+dir=${GAMES_DATADIR}/${PN}
+
+src_prepare() {
+ # Disable OpenGL support if USE flag is not set
+ if ! use opengl ; then
+ sed -i \
+ -e 's: -DHAVE_GL::' \
+ -e 's: -lGL::' \
+ configure.in || die "sed failed"
+ fi
+
+ sed -i '$ s/\\//' \
+ src/lua/Makefile.am \
+ src/maps/battle/Makefile.am \
+ || die "sed failed"
+
+ epatch "${FILESDIR}"/${P}-underlink.patch
+
+ eautoreconf
+
+ cd src
+
+ # Save to HOME
+ epatch "${FILESDIR}"/${P}-save.patch
+
+ # Modify game data & scrips path
+ sed -i \
+ -e "s:gui/:${dir}/gui/:" \
+ -e "s:sounds/:${dir}/sounds/:" \
+ gui.c || die "sed gui.c failed"
+ sed -i \
+ -e "s:images/:${dir}/images/:" \
+ -e "s:textures/:${dir}/textures/:" \
+ go_sdl.c || die "sed go_sdl.c failed"
+ sed -i \
+ -e "s:textures/:${dir}/textures/:" \
+ go_gl.c || die "sed go_gl.c failed"
+ sed -i \
+ -e "s:input.lua:${dir}/input.lua:" \
+ gi_sdl.c || die "sed gi_sdl.c failed"
+ sed -i \
+ -e "s:images/:${dir}/images/:" \
+ anim.c output.c || die "sed anim.c output.c failed"
+ sed -i \
+ -e "s:maps/:${dir}/maps/:" \
+ load_maps.lua || die "sed load_maps.lua failed"
+ sed -i \
+ -e "s:sounds/:${dir}/sounds/:" \
+ audio_sdl.c || die "sed audio_sdl.c failed"
+ sed -i \
+ -e "s:load_maps.lua:${dir}/load_maps.lua:" \
+ map.c || die "sed map.c failed"
+}
+
+src_install() {
+ # Remove makefiles before installation
+ rm -f src/*/Makefile* src/*/*/Makefile* || die "removing makefiles"
+ insinto "${dir}"
+ doins -r src/{gui,images,sounds,textures,maps,*.lua}
+ dodoc README TODO ChangeLog AUTHORS
+ dogamesbin src/mures
+
+ prepgamesdirs
+}