summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-22 18:08:23 +0200
committerMart Raudsepp <leio@gentoo.org>2020-03-22 18:08:33 +0200
commit8fa40edf9f89828b8084a4fe0ddacbf92dab9473 (patch)
tree0d0dab9527d8a108fb81fdb98203b2f48644781b /games-puzzle/gnome2048/gnome2048-3.36.0.ebuild
parentapp-office/gnome-todo: initial import from gnome overlay (diff)
downloadgentoo-8fa40edf9f89828b8084a4fe0ddacbf92dab9473.tar.gz
gentoo-8fa40edf9f89828b8084a4fe0ddacbf92dab9473.tar.bz2
gentoo-8fa40edf9f89828b8084a4fe0ddacbf92dab9473.zip
games-puzzle/gnome2048: initial import
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'games-puzzle/gnome2048/gnome2048-3.36.0.ebuild')
-rw-r--r--games-puzzle/gnome2048/gnome2048-3.36.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-puzzle/gnome2048/gnome2048-3.36.0.ebuild b/games-puzzle/gnome2048/gnome2048-3.36.0.ebuild
new file mode 100644
index 000000000000..5eae653dcd4c
--- /dev/null
+++ b/games-puzzle/gnome2048/gnome2048-3.36.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="gnome-2048"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Move the tiles until you obtain the 2048 tile"
+HOMEPAGE="https://wiki.gnome.org/Apps/2048"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.42.0:2
+ >=x11-libs/gtk+-3.22.23:3
+ >=media-libs/clutter-1.12.0:1.0
+ >=media-libs/clutter-gtk-1.6.0:1.0
+ >=dev-libs/libgee-0.14.0:0.8
+ dev-libs/libgnome-games-support:1=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}