summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/cuyo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/cuyo')
-rw-r--r--games-puzzle/cuyo/Manifest1
-rw-r--r--games-puzzle/cuyo/cuyo-2.1.1.ebuild51
-rw-r--r--games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch11
-rw-r--r--games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch30
-rw-r--r--games-puzzle/cuyo/metadata.xml8
5 files changed, 101 insertions, 0 deletions
diff --git a/games-puzzle/cuyo/Manifest b/games-puzzle/cuyo/Manifest
new file mode 100644
index 000000000000..0c67f68f77f2
--- /dev/null
+++ b/games-puzzle/cuyo/Manifest
@@ -0,0 +1 @@
+DIST cuyo-2.~-1.1.tar.gz 3005426 SHA256 7157aa70ae731c17e765fba11736866f2020826ad6187d8df6c55039d4481de6 SHA512 a29c6ffc7e63b74dd93e8aeeace78bdbc50398771922aaf06a43256c883f9eff23e10fa91e4964b716cd209551cef771cf00108fb7977ce13a463da542322787 WHIRLPOOL ef2817feecbe9c785e8d6438aca123247857c8f9845421a5aef89375b0f9c15a050d0e6f16791cab408f8e87a9640ef0cbc77c9cc89f03c5e788d3851b07af2d
diff --git a/games-puzzle/cuyo/cuyo-2.1.1.ebuild b/games-puzzle/cuyo/cuyo-2.1.1.ebuild
new file mode 100644
index 000000000000..a4227a912241
--- /dev/null
+++ b/games-puzzle/cuyo/cuyo-2.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils gnome2-utils versionator games
+
+MY_P=${PN}-$(get_version_component_range 1).~-$(get_version_component_range 2-3)
+DESCRIPTION="highly addictive and remotely related to tetris"
+HOMEPAGE="http://www.karimmi.de/cuyo/"
+SRC_URI="http://savannah.nongnu.org/download/cuyo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="+music"
+
+DEPEND="sys-libs/zlib
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer
+ music? ( media-libs/sdl-mixer[mod] )
+ media-libs/sdl-image"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch b/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch
new file mode 100644
index 000000000000..9ad50b067fb5
--- /dev/null
+++ b/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch
@@ -0,0 +1,11 @@
+--- cuyo-2.~-1.1.orig/src/stringzeug.h
++++ cuyo-2.~-1.1/src/stringzeug.h
+@@ -20,7 +20,7 @@
+
+ #include <config.h>
+ #include <string>
+-
++#include <stdio.h>
+
+
+
diff --git a/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch b/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch
new file mode 100644
index 000000000000..78bafe2ded47
--- /dev/null
+++ b/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch
@@ -0,0 +1,30 @@
+--- cuyo-2.~-1.1.orig/icons/Makefile.am
++++ cuyo-2.~-1.1/icons/Makefile.am
+@@ -1,4 +1,4 @@
+-desktopdir = $(datadir)/applications
++desktopdir = /usr/share/applications
+ desktop_DATA = cuyo.desktop
+
+
+@@ -25,7 +25,7 @@
+ # Das vorige war falsch: die png sollen alle cuyo.png heissen
+ # und nicht cuyo-xxxx.png. Deshalb nachfolgend neue Version:
+
+-iconsdir = $(datadir)/icons/hicolor
++iconsdir = /usr/share/icons/hicolor
+ icons_DATA = cuyo-32x32.png cuyo-64x64.png
+
+ install-iconsDATA:
+--- cuyo-2.~-1.1.orig/icons/cuyo.desktop
++++ cuyo-2.~-1.1/icons/cuyo.desktop
+@@ -3,9 +3,8 @@
+ Icon=cuyo
+ Type=Application
+ Terminal=false
+-MimeType=application/x-executable
++MimeType=application/x-executable;
+ Categories=Game;BlocksGame;
+-Encoding=UTF-8
+ Comment=A tetris like game with many levels
+ Comment[de]=Ein Tetris-artiges Spiel mit vielen Leveln
+ Exec=cuyo
diff --git a/games-puzzle/cuyo/metadata.xml b/games-puzzle/cuyo/metadata.xml
new file mode 100644
index 000000000000..658a1ecd0c6d
--- /dev/null
+++ b/games-puzzle/cuyo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<use>
+ <flag name="music">Enable playing of background music</flag>
+</use>
+</pkgmetadata>