summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-kids/lletters/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-kids/lletters/files')
-rw-r--r--games-kids/lletters/files/lletters-0.1.95-build-2.patch60
-rw-r--r--games-kids/lletters/files/lletters-0.1.95-make-382.patch23
-rw-r--r--games-kids/lletters/files/lletters-0.1.95-underlink.patch11
3 files changed, 94 insertions, 0 deletions
diff --git a/games-kids/lletters/files/lletters-0.1.95-build-2.patch b/games-kids/lletters/files/lletters-0.1.95-build-2.patch
new file mode 100644
index 000000000000..41e10517faf9
--- /dev/null
+++ b/games-kids/lletters/files/lletters-0.1.95-build-2.patch
@@ -0,0 +1,60 @@
+diff -ur lletters-0.1.95.orig/libqdwav/Makefile.in lletters-0.1.95/libqdwav/Makefile.in
+--- lletters-0.1.95.orig/libqdwav/Makefile.in 2008-04-09 19:23:13.000000000 +0300
++++ lletters-0.1.95/libqdwav/Makefile.in 2008-04-09 19:48:08.000000000 +0300
+@@ -225,7 +225,6 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ noinst_LIBRARIES = libqdwav.a
+-AM_CFLAGS = -O2
+ libqdwav_a_SOURCES = wav_read.c wav_write.c
+ noinst_HEADERS = wav_lib.h
+ all: all-am
+diff -ur lletters-0.1.95.orig/libqdwav/wav_read.c lletters-0.1.95/libqdwav/wav_read.c
+--- lletters-0.1.95.orig/libqdwav/wav_read.c 2000-02-21 09:53:08.000000000 +0200
++++ lletters-0.1.95/libqdwav/wav_read.c 2008-04-09 19:51:23.000000000 +0300
+@@ -1,5 +1,6 @@
+ /* operations for verifying and reading wav files. */
+
++#include <string.h> /* for strs */
+ #include <stdio.h>
+ #include <fcntl.h>
+ #include <sys/stat.h>
+diff -ur lletters-0.1.95.orig/libqdwav/wav_write.c lletters-0.1.95/libqdwav/wav_write.c
+--- lletters-0.1.95.orig/libqdwav/wav_write.c 2008-04-09 19:23:13.000000000 +0300
++++ lletters-0.1.95/libqdwav/wav_write.c 2008-04-09 19:51:28.000000000 +0300
+@@ -1,3 +1,4 @@
++#include <string.h> /* for strs */
+ #include <stdio.h>
+ #include <fcntl.h>
+ #include <signal.h>
+diff -ur lletters-0.1.95.orig/list.c lletters-0.1.95/list.c
+--- lletters-0.1.95.orig/list.c 2000-02-23 06:54:57.000000000 +0200
++++ lletters-0.1.95/list.c 2008-04-09 19:51:35.000000000 +0300
+@@ -1,3 +1,4 @@
++#include <string.h> /* for strs */
+ #include "lletters.h"
+
+ /* prototype std lib functions */
+diff -ur lletters-0.1.95.orig/po/Makefile.in.in lletters-0.1.95/po/Makefile.in.in
+--- lletters-0.1.95.orig/po/Makefile.in.in 2008-04-09 19:23:13.000000000 +0300
++++ lletters-0.1.95/po/Makefile.in.in 2008-04-09 19:48:08.000000000 +0300
+@@ -111,9 +111,9 @@
+ install-data-no: all
+ install-data-yes: all
+ if test -r "$(MKINSTALLDIRS)"; then \
+- $(MKINSTALLDIRS) $(datadir); \
++ $(MKINSTALLDIRS) $(DESTDIR)$(datadir); \
+ else \
+- $(SHELL) $(top_srcdir)/mkinstalldirs $(datadir); \
++ $(SHELL) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(datadir); \
+ fi
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+@@ -122,6 +122,7 @@
+ *.gmo) destdir=$(gnulocaledir);; \
+ *) destdir=$(localedir);; \
+ esac; \
++ destdir="$(DESTDIR)$$destdir"; \
+ lang=`echo $$cat | sed 's/\$(CATOBJEXT)$$//'`; \
+ dir=$$destdir/$$lang/LC_MESSAGES; \
+ if test -r "$(MKINSTALLDIRS)"; then \
diff --git a/games-kids/lletters/files/lletters-0.1.95-make-382.patch b/games-kids/lletters/files/lletters-0.1.95-make-382.patch
new file mode 100644
index 000000000000..2a5ee9ecc4a7
--- /dev/null
+++ b/games-kids/lletters/files/lletters-0.1.95-make-382.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/340599
+
+--- intl/Makefile.in
++++ intl/Makefile.in
+@@ -202,12 +202,12 @@
+ # The dependency for intlh.inst is different in gettext and all other
+ # packages. Because we cannot you GNU make features we have to solve
+ # the problem while rewriting Makefile.in.
+-@GT_YES@intlh.inst: intlh.inst.in ../config.status
+-@GT_YES@ cd .. \
+-@GT_YES@ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
+-@GT_YES@ $(SHELL) ./config.status
+-@GT_NO@.PHONY: intlh.inst
+-@GT_NO@intlh.inst:
++intlh.inst: intlh.inst.in ../config.status
++ cd .. \
++ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
++ $(SHELL) ./config.status
++.PHONY: intlh.inst
++intlh.inst:
+
+ # Tell versions [3.59,3.63) of GNU make not to export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/games-kids/lletters/files/lletters-0.1.95-underlink.patch b/games-kids/lletters/files/lletters-0.1.95-underlink.patch
new file mode 100644
index 000000000000..a6e0a27ee4e9
--- /dev/null
+++ b/games-kids/lletters/files/lletters-0.1.95-underlink.patch
@@ -0,0 +1,11 @@
+--- Makefile.in.old 2011-05-24 10:47:30.276355207 +0200
++++ Makefile.in 2011-05-24 10:47:53.316795932 +0200
+@@ -265,7 +265,7 @@
+
+ @SOUND_FALSE@lletters_SOURCES = $(lln_CORE)
+ @SOUND_TRUE@lletters_SOURCES = $(lln_CORE) wav_play.c $(sound_CORE)
+-@SOUND_TRUE@lletters_LDADD = libqdwav/libqdwav.a -lgdk_pixbuf-2.0 -lglib-2.0 -lgtk-x11-2.0
++@SOUND_TRUE@lletters_LDADD = libqdwav/libqdwav.a @GTK_LIBS@
+
+ #lletters_LDADD = #@GTK_LIBS@
+ @SOUND_FALSE@SUBDIRS = intl po images lang