summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-09-24 15:03:50 +1000
committerMatt Jolly <kangie@gentoo.org>2024-09-24 16:30:37 +1000
commitc3bfff089d2d1ef64f141f2775d95fc636b0aaa1 (patch)
tree2178b70eb34c86caf89de5b9bd2b1f2a14392781 /games-fps
parentgames-fps/alephone-durandal: drop 20221126 (diff)
downloadgentoo-c3bfff089d2d1ef64f141f2775d95fc636b0aaa1.tar.gz
gentoo-c3bfff089d2d1ef64f141f2775d95fc636b0aaa1.tar.bz2
gentoo-c3bfff089d2d1ef64f141f2775d95fc636b0aaa1.zip
games-fps/alephone-infinity: add 20240822
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alephone-infinity/Manifest1
-rw-r--r--games-fps/alephone-infinity/alephone-infinity-20240822.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/games-fps/alephone-infinity/Manifest b/games-fps/alephone-infinity/Manifest
index 9c29ddec2a66..92bbb63dad56 100644
--- a/games-fps/alephone-infinity/Manifest
+++ b/games-fps/alephone-infinity/Manifest
@@ -1 +1,2 @@
DIST MarathonInfinity-20221126-Data.zip 32204262 BLAKE2B 35292a53b9983411c4fd07f4c424950c8d2588132f75153ce88d6b97fbb43638985be3f254c7ce847a5eb63fbaf757a0b3914d23fd3025bd1f4d8a7f374691da SHA512 8e245618d0ed9ed3b7944360fa2db36f9cc255510c04c8d45f168a43ed398965ebc5551b604cc59b51b37cacbf41ac0e4aaced046704cb095dadd4e585d2763a
+DIST MarathonInfinity-20240822-Data.zip 31852152 BLAKE2B 8360a413a9d813b315d7c012965fa54ad480a99dad4e44135d2e4fbab96fa92b604f9004a0a0456f86fbda070c28c7fb504ad2d7aa7347eeb53633b036320d75 SHA512 354dac31983d5ff516c8326fdb915411d06b27a6e3089c0ced9723d1604aacce2e1cb299e1c59cbea06180c388472a8757091582c232693ae7c219bd9bb774a9
diff --git a/games-fps/alephone-infinity/alephone-infinity-20240822.ebuild b/games-fps/alephone-infinity/alephone-infinity-20240822.ebuild
new file mode 100644
index 000000000000..05045fa23f0e
--- /dev/null
+++ b/games-fps/alephone-infinity/alephone-infinity-20240822.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Aleph One - Marathon Infinity"
+HOMEPAGE="https://alephone.lhowon.org/"
+SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/MarathonInfinity-${PV}-Data.zip"
+S="${WORKDIR}/Marathon Infinity"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+BDEPEND="app-arch/unzip"
+
+MY_NAME="infinity"
+MY_DIR="/usr/share/alephone-${MY_NAME}"
+
+src_install() {
+ insinto "${MY_DIR}"
+ doins -r *
+
+ make_desktop_entry "alephone.sh ${MY_NAME}" "${DESCRIPTION}"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${MY_DIR}"/{Scripts,"Physics Models",Textures,Themes}
+}
+
+pkg_postinst() {
+ elog "To play this scenario, run:"
+ elog "alephone.sh ${MY_NAME}"
+}