summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2023-01-28 21:03:22 +1100
committerSam James <sam@gentoo.org>2023-01-31 05:58:23 +0000
commit7a764027a90d303368bccecd6f703b0b6543fbea (patch)
treef7f919ebc787425a2a834d637a959e6364b82725 /games-fps
parentnet-analyzer/wtfis: Stabilize 0.5.1 amd64, #892661 (diff)
downloadgentoo-7a764027a90d303368bccecd6f703b0b6543fbea.tar.gz
gentoo-7a764027a90d303368bccecd6f703b0b6543fbea.tar.bz2
gentoo-7a764027a90d303368bccecd6f703b0b6543fbea.zip
games-fps/alephone: add 20230119, drop 20221126
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Closes: https://github.com/gentoo/gentoo/pull/29314 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alephone/Manifest2
-rw-r--r--games-fps/alephone/alephone-20230119.ebuild (renamed from games-fps/alephone/alephone-20221126.ebuild)4
-rw-r--r--games-fps/alephone/alephone-99999999.ebuild2
-rw-r--r--games-fps/alephone/files/alephone-20230119-c99.patch99
4 files changed, 104 insertions, 3 deletions
diff --git a/games-fps/alephone/Manifest b/games-fps/alephone/Manifest
index e0f3565ec87f..24554b54aee2 100644
--- a/games-fps/alephone/Manifest
+++ b/games-fps/alephone/Manifest
@@ -1 +1 @@
-DIST release-20221126.tar.gz 6968670 BLAKE2B d4437f845fd9cc1c6f99620e3ff5b2e5e3fabda82622343589246999ee8c654f4762a0a2e13fc9e595ec34d1d1db7a114b4f8436967da559737af8ca86bfd559 SHA512 ca6acc4de03b65c27829c57bfabd7f6e49e78111c94aac29cf03aeb8606c9c6d8e56a477ebfbbd0b6079b2d8ed0946717883de27855532917ac4758ab43d108d
+DIST release-20230119.tar.gz 6968352 BLAKE2B 06bc87b4c2bc6a311ee90f854f7c35fb4da2862c417b192a4364dbd38cac9c0c02c4439abf07e6bc7c2d68899fae4dd938464896039943f1fa6ae5a4a644260f SHA512 d1ede53c20a24b74f5525e2e8c09fdbbb05fa0262bbd8f6c1abe6c3698cdfd1dea2436487ec8f64c79a7e1f150367e40ea48838f8a42031b45c0b1498a0e77d1
diff --git a/games-fps/alephone/alephone-20221126.ebuild b/games-fps/alephone/alephone-20230119.ebuild
index 70b887308564..67bf15ff6d89 100644
--- a/games-fps/alephone/alephone-20221126.ebuild
+++ b/games-fps/alephone/alephone-20230119.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -57,6 +57,8 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}/${P}-c99.patch" )
+
src_prepare() {
default
eautoreconf
diff --git a/games-fps/alephone/alephone-99999999.ebuild b/games-fps/alephone/alephone-99999999.ebuild
index 70b887308564..15a4810f346c 100644
--- a/games-fps/alephone/alephone-99999999.ebuild
+++ b/games-fps/alephone/alephone-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
diff --git a/games-fps/alephone/files/alephone-20230119-c99.patch b/games-fps/alephone/files/alephone-20230119-c99.patch
new file mode 100644
index 000000000000..7340e1fb2be0
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20230119-c99.patch
@@ -0,0 +1,99 @@
+https://github.com/Aleph-One-Marathon/alephone/pull/405
+From: Matt Jolly <Matt.Jolly@footclan.ninja>
+Date: Sat, 28 Jan 2023 18:03:51 +1100
+Subject: [PATCH] use designated initialisers for SDL_ffmpegCodec*
+
+These were failing to compile under clang16 as the old `audioBitrate`
+was being jammed into `crf`, causing an incompatible integer conversion.
+--- a/Source_Files/FFmpeg/SDL_ffmpeg.c
++++ b/Source_Files/FFmpeg/SDL_ffmpeg.c
+@@ -155,41 +155,55 @@ int SDL_ffmpegDecodeVideoFrame( SDL_ffmpegFile*, AVPacket*, SDL_ffmpegVideoFrame
+
+ const SDL_ffmpegCodec SDL_ffmpegCodecAUTO =
+ {
+- -1,
+- 720, 576,
+- 1, 25,
+- 6000000,
+- -1, -1,
+- -1,
+- 2, 48000,
+- 192000,
+- -1, -1
++ .videoCodecID=-1,
++ .width=720,
++ .height=576,
++ .framerateNum=1,
++ .framerateDen=25,
++ .videoBitrate=6000000,
++ .videoMinRate=-1,
++ .videoMaxRate=-1,
++ .audioCodecID=-1,
++ .channels=2,
++ .sampleRate=48000,
++ .cpuCount=-1,
++ .audioQuality=-1
+ };
+
++
++
+ const SDL_ffmpegCodec SDL_ffmpegCodecPALDVD =
+ {
+- AV_CODEC_ID_MPEG2VIDEO,
+- 720, 576,
+- 1, 25,
+- 6000000,
+- -1, -1,
+- AV_CODEC_ID_MP2,
+- 2, 48000,
+- 192000,
+- -1, -1
++ .videoCodecID=AV_CODEC_ID_MPEG2VIDEO,
++ .width=720,
++ .height=576,
++ .framerateNum=1,
++ .framerateDen=25,
++ .videoBitrate=6000000,
++ .videoMinRate=-1,
++ .videoMaxRate=-1,
++ .audioCodecID=AV_CODEC_ID_MP2,
++ .channels=2,
++ .sampleRate=48000,
++ .cpuCount=-1,
++ .audioQuality=-1
+ };
+
+ const SDL_ffmpegCodec SDL_ffmpegCodecPALDV =
+ {
+- AV_CODEC_ID_DVVIDEO,
+- 720, 576,
+- 1, 25,
+- 6553600,
+- -1, -1,
+- AV_CODEC_ID_DVAUDIO,
+- 2, 48000,
+- 256000,
+- -1, -1
++ .videoCodecID=AV_CODEC_ID_DVVIDEO,
++ .width=720,
++ .height=576,
++ .framerateNum=1,
++ .framerateDen=25,
++ .videoBitrate=6553600,
++ .videoMinRate=-1,
++ .videoMaxRate=-1,
++ .audioCodecID=AV_CODEC_ID_DVAUDIO,
++ .channels=2,
++ .sampleRate=48000,
++ .cpuCount=-1,
++ .audioQuality=-1
+ };
+
+ SDL_ffmpegFile* SDL_ffmpegCreateFile()
+@@ -2269,4 +2283,4 @@ int SDL_ffmpegDecodeVideoFrame( SDL_ffmpegFile* file, AVPacket *pack, SDL_ffmpeg
+ /**
+ \endcond
+ */
+-#endif
+\ No newline at end of file
++#endif