summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/rtcw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/rtcw')
-rw-r--r--games-fps/rtcw/Manifest2
-rw-r--r--games-fps/rtcw/files/wolf-ded.rc25
-rw-r--r--games-fps/rtcw/metadata.xml8
-rw-r--r--games-fps/rtcw/rtcw-1.41b.ebuild95
4 files changed, 130 insertions, 0 deletions
diff --git a/games-fps/rtcw/Manifest b/games-fps/rtcw/Manifest
new file mode 100644
index 000000000000..99ad55385120
--- /dev/null
+++ b/games-fps/rtcw/Manifest
@@ -0,0 +1,2 @@
+DIST wolf-linux-1.41b.x86.run 73940068 SHA256 2921425c1b429147c1bc6f0c6a8664bec502ae86a2d6bccfaa1162f75dce89f3 SHA512 8c018bcdeca5b14fe1b8c35f46031416978b27b57a38897fa5b1b0c26fbf3ab6f44c22582223ad98a695a793ba1444a2e092beee687e835a279a12121422e93f WHIRLPOOL 647a76f07d01be737340bf36e552e25b5595b3defc09cee9deac3b8dda27db9579158ca91010bbf73e1af7586c8ad73003565c4a57e6ae79850377ecf512103e
+DIST wolf-linux-GOTY-maps.x86.run 51930759 SHA256 d80994fc3c89348ac08b616f0e03d6cfca3d2faae89491dd294501cac1cad952 SHA512 85f334f75d538bb68c7507d36600b433b0ab0c92572c8e8c022eaeb8783fc72d56ff39ee0ee9eb3272ab09025bca56cca70b077b7e7b02a38cd556fb9f425dcc WHIRLPOOL 731ee47d3631c705057b45f870d29d87988b54a882ffd22c75c5bb5e7e2ec6a7e27baf89fb7a4715f133b649c5b99bed6bc47cb87ba0cd8c9583044361b7c9c8
diff --git a/games-fps/rtcw/files/wolf-ded.rc b/games-fps/rtcw/files/wolf-ded.rc
new file mode 100644
index 000000000000..e3d3879ae12c
--- /dev/null
+++ b/games-fps/rtcw/files/wolf-ded.rc
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting RTCW dedicated server..."
+ screen -A -m -d -S rtcw su - dedicated -c GENTOO_DIR/startwolfded
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping RTCW dedicated server..."
+ kill `screen -list | grep rtcw | awk -F . '{ print $1 }' | sed -e s/.//`
+ eend $?
+
+}
+
+status() {
+ screen -list | grep rtcwded
+}
diff --git a/games-fps/rtcw/metadata.xml b/games-fps/rtcw/metadata.xml
new file mode 100644
index 000000000000..a3e346eff6e9
--- /dev/null
+++ b/games-fps/rtcw/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Return to Castle Wolfenstein is a first-person 3-D shooter based loosely on the original Wolfenstein series by id software. The game takes place in Europe during World War II. In the single player game, you play as a US military special operative sent behind enemy lines to stop the Nazi studies into the supernatural and the occult. The multi-player game is a team-based, goal-oriented series of missions and allows you to play as either the Axis or the Allies. There are several classes of characters you can play, each with their own special abilities and weapon choices. The port to Linux was done by TTimo of id software and is an unsupported binary release. This game is commercial software and requires data from the retail Windows version to play.
+</longdescription>
+</pkgmetadata>
diff --git a/games-fps/rtcw/rtcw-1.41b.ebuild b/games-fps/rtcw/rtcw-1.41b.ebuild
new file mode 100644
index 000000000000..3aae89d7e0e4
--- /dev/null
+++ b/games-fps/rtcw/rtcw-1.41b.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+DESCRIPTION="Return to Castle Wolfenstein - Long awaited sequel to Wolfenstein 3D"
+HOMEPAGE="http://games.activision.com/games/wolfenstein/"
+SRC_URI="mirror://idsoftware/wolf/linux/wolf-linux-GOTY-maps.x86.run
+ mirror://idsoftware/wolf/linux/wolf-linux-${PV}.x86.run"
+# mirror://3dgamers/returnwolfenstein/wolf-linux-${PV}.x86.run
+
+LICENSE="RTCW GPL-2" # gpl for init script bug #425944
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="opengl dedicated"
+RESTRICT="strip mirror"
+
+UIDEPEND="x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]"
+RDEPEND="sys-libs/glibc
+ sys-libs/lib-compat
+ dedicated? ( app-misc/screen )
+ !dedicated? ( ${UIDEPEND} )
+ opengl? ( ${UIDEPEND} )"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/* ${dir:1}/pb/* ${dir:1}/main/*"
+
+src_install() {
+ insinto "${dir}"
+ doins -r main Docs pb
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/*.x86 openurl.sh
+
+ games_make_wrapper rtcwmp ./wolf.x86 "${dir}" "${dir}"
+ games_make_wrapper rtcwsp ./wolfsp.x86 "${dir}" "${dir}"
+ # work around buggy video driver (bug #326837)
+ sed -i \
+ -e 's/^exec /__GL_ExtensionStringVersion=17700 exec /' \
+ "${D}/${GAMES_BINDIR}/rtcwsp" \
+ || die
+
+ if use dedicated; then
+ games_make_wrapper wolf-ded ./wolfded.x86 "${dir}" "${dir}"
+ newinitd "${FILESDIR}"/wolf-ded.rc wolf-ded
+ sed -i \
+ -e "s:GENTOO_DIR:${dir}:" \
+ "${D}"/etc/init.d/wolf-ded \
+ || die
+ fi
+
+ insinto ${dir}
+ doins WolfMP.xpm WolfSP.xpm QUICKSTART CHANGES RTCW-README-1.4.txt
+ doicon WolfMP.xpm WolfSP.xpm
+
+ prepgamesdirs
+ make_desktop_entry rtcwmp "Return to Castle Wolfenstein (MP)" WolfMP
+ make_desktop_entry rtcwsp "Return to Castle Wolfenstein (SP)" WolfSP
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "There are two possible security bugs in this package, both causing a"
+ ewarn "denial of service. One affects the game when running a server, the"
+ ewarn "other when running as a client."
+ ewarn "For more information, see bug #82149."
+ echo
+ elog "You need to copy pak0.pk3, mp_pak0.pk3, mp_pak1.pk3, mp_pak2.pk3,"
+ elog "sp_pak1.pk3 and sp_pak2.pk3 from a Window installation into ${dir}/main/"
+ elog
+ elog "To play the game run:"
+ elog " rtcwsp (single-player)"
+ elog " rtcwmp (multi-player)"
+ elog
+ if use dedicated
+ then
+ elog "To start a dedicated server run:"
+ elog " /etc/init.d/wolf-ded start"
+ elog
+ elog "To run the dedicated server at boot, type:"
+ elog " rc-update add wolf-ded default"
+ elog
+ elog "The dedicated server is started under the ${GAMES_USER_DED} user account"
+ echo
+ fi
+}