summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-05-30 16:22:05 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-05-30 16:22:05 +0100
commitcee98c7731e99aa2044f81c9429f8609485c6da0 (patch)
tree1ecb762265209c9ba947773d776741a299770109 /games-engines
parentsci-libs/pyshp: Add python 3_10 support (diff)
downloadgentoo-cee98c7731e99aa2044f81c9429f8609485c6da0.tar.gz
gentoo-cee98c7731e99aa2044f81c9429f8609485c6da0.tar.bz2
gentoo-cee98c7731e99aa2044f81c9429f8609485c6da0.zip
games-engines/scummvm: Add sndio USE flag, fixing automagic dependency
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/metadata.xml1
-rw-r--r--games-engines/scummvm/scummvm-2.2.0-r1.ebuild3
-rw-r--r--games-engines/scummvm/scummvm-9999.ebuild5
3 files changed, 6 insertions, 3 deletions
diff --git a/games-engines/scummvm/metadata.xml b/games-engines/scummvm/metadata.xml
index dd278d4911d0..4b13f3aa2adc 100644
--- a/games-engines/scummvm/metadata.xml
+++ b/games-engines/scummvm/metadata.xml
@@ -15,6 +15,7 @@
<flag name="glew">enable support for OpenGL Extension Wrangler Library (<pkg>media-libs/glew</pkg>)</flag>
<flag name="mpeg2">enable mpeg2 codec for cutscenes</flag>
<flag name="net">enable cloud support via <pkg>media-libs/sdl2-net</pkg></flag>
+ <flag name="sndio">Enable support for MIDI music using <pkg>media-sound/sndio</pkg></flag>
<flag name="speech">enable text-to-speech support through <pkg>app-accessibility/speech-dispatcher</pkg></flag>
<flag name="unsupported">enable unsupported and/or broken game engines (you're on your own)</flag>
</use>
diff --git a/games-engines/scummvm/scummvm-2.2.0-r1.ebuild b/games-engines/scummvm/scummvm-2.2.0-r1.ebuild
index f4ab2f0515e9..b6022c564f3f 100644
--- a/games-engines/scummvm/scummvm-2.2.0-r1.ebuild
+++ b/games-engines/scummvm/scummvm-2.2.0-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://scummvm.org/frs/scummvm/${PV}/${P}.tar.xz"
LICENSE="GPL-2+ LGPL-2.1 BSD GPL-3-with-font-exception"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="a52 aac alsa debug flac fluidsynth fribidi +gtk jpeg lua mpeg2 mp3 +net opengl png speech theora truetype unsupported vorbis zlib"
+IUSE="a52 aac alsa debug flac fluidsynth fribidi +gtk jpeg lua mpeg2 mp3 +net opengl png sndio speech theora truetype unsupported vorbis zlib"
RESTRICT="test" # it only looks like there's a test there #77507
RDEPEND="
@@ -99,6 +99,7 @@ src_configure() {
$(use_enable mpeg2)
$(use_enable net sdlnet)
$(use_enable png)
+ $(use_enable sndio)
$(use_enable speech tts)
$(use_enable theora theoradec)
$(use_enable truetype freetype2)
diff --git a/games-engines/scummvm/scummvm-9999.ebuild b/games-engines/scummvm/scummvm-9999.ebuild
index 22e410bbb259..f6a91ef83cd0 100644
--- a/games-engines/scummvm/scummvm-9999.ebuild
+++ b/games-engines/scummvm/scummvm-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,7 @@ EGIT_REPO_URI="https://github.com/scummvm/scummvm"
LICENSE="GPL-2+ LGPL-2.1 BSD GPL-3-with-font-exception"
SLOT="0"
KEYWORDS=""
-IUSE="a52 aac alsa debug flac fluidsynth fribidi glew +gtk jpeg lua mpeg2 mp3 +net opengl png speech theora truetype unsupported vorbis zlib"
+IUSE="a52 aac alsa debug flac fluidsynth fribidi glew +gtk jpeg lua mpeg2 mp3 +net opengl png sndio speech theora truetype unsupported vorbis zlib"
RESTRICT="test" # it only looks like there's a test there #77507
RDEPEND="
@@ -98,6 +98,7 @@ src_configure() {
$(use_enable mpeg2)
$(use_enable net sdlnet)
$(use_enable png)
+ $(use_enable sndio)
$(use_enable speech tts)
$(use_enable theora theoradec)
$(use_enable truetype freetype2)