summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-05-08 21:44:13 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-05-08 21:44:13 -0400
commit23a37c9b1224d607a6401b13ddd897cb198a3d59 (patch)
treeb76740b32673692c736ecea0e8d3ba306051f6d1 /games-emulation
parentprofiles: media-libs/csfml and dev-python/pysfml are gone (diff)
downloadgentoo-23a37c9b1224d607a6401b13ddd897cb198a3d59.tar.gz
gentoo-23a37c9b1224d607a6401b13ddd897cb198a3d59.tar.bz2
gentoo-23a37c9b1224d607a6401b13ddd897cb198a3d59.zip
games-emulation/dolphin: clean old (last user of libsfml-1)
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dolphin/Manifest2
-rw-r--r--games-emulation/dolphin/dolphin-4.0-r2.ebuild154
-rw-r--r--games-emulation/dolphin/dolphin-4.0.2-r7.ebuild155
3 files changed, 0 insertions, 311 deletions
diff --git a/games-emulation/dolphin/Manifest b/games-emulation/dolphin/Manifest
index 7bdb0972b6a0..2cc1c502ab08 100644
--- a/games-emulation/dolphin/Manifest
+++ b/games-emulation/dolphin/Manifest
@@ -1,3 +1 @@
-DIST dolphin-4.0.2.zip 28261421 SHA256 f20c824ee83c3a495fd019747d2f8254477b94c135415b386142f89716d05d66 SHA512 5b1931a133fd431b8f03f47c4c1cfe89f752de17f792e2729421df439564d15a8e35b17e82e31cef99230157de4aa16b2572b28ad67f23ca23c5492972df2938 WHIRLPOOL 48dcc47de02e6aa25e5318bc2564df1ab510210556e3e7c9442f405abd04879b8cff85afb5f1fa7a36364902a472f18bf5fa8da3a9db59b915d41d4e60f3b235
-DIST dolphin-4.0.zip 23439392 SHA256 a698caf05f47a55c30e09d0aab053a412df683de2e139a6348156b03c502a0ec SHA512 02e366c2fa95ab5f37b0a66b94a5b56a632ef81e13febd982d6385cfaf7fa3edb4364180d4b8312e82bc7b8f150d02cde10248996f6a12286a20d684024aca20 WHIRLPOOL 0cb7b28b911111f4b7bf93c56f2dd31d080e7e0418fb53d9cc9093ca995d2c99a1fa7d5d82111e2c8db363e2b07384be39ec0062ab0252233f480b8e45e9304e
DIST dolphin-5.0.zip 28317729 SHA256 2b1003360d52baf12a1bcd4d75f379749b0fd4001948ec1a24d0539c37aae055 SHA512 1b1c0dd6da4ba7e9ffe30499fae582b922c9bbd8b3d8159fbf9f4bfa1e744ef5b4c00a85d34f7cdd6e01efa32133f59b2a1f42cafc9d620f7fc7462c4ba73615 WHIRLPOOL 73cc25bafcb0d32592e8ad799b0a3d458cfa944ad15380a3b8f1cf27f3e024c314b08469a17f6d92edced95631bba38e39e1ccd625227c0520813abbd399e0f4
diff --git a/games-emulation/dolphin/dolphin-4.0-r2.ebuild b/games-emulation/dolphin/dolphin-4.0-r2.ebuild
deleted file mode 100644
index a326e47d88fa..000000000000
--- a/games-emulation/dolphin/dolphin-4.0-r2.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-WX_GTK_VER="2.9"
-
-inherit cmake-utils eutils pax-utils toolchain-funcs versionator wxwidgets games
-
-SRC_URI="https://github.com/${PN}-emu/${PN}/archive/${PV}.zip -> ${P}.zip"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Gamecube and Wii game emulator"
-HOMEPAGE="https://www.dolphin-emu.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="alsa ao bluetooth doc ffmpeg +lzo openal opengl openmp portaudio pulseaudio"
-
-RESTRICT="mirror"
-
-RDEPEND=">=media-libs/glew-1.6
- >=media-libs/libsdl-1.2[joystick]
- <media-libs/libsfml-2.0
- >=net-libs/miniupnpc-1.8
- sys-libs/readline:=
- x11-libs/libXext
- x11-libs/libXrandr
- alsa? ( media-libs/alsa-lib )
- ao? ( media-libs/libao )
- bluetooth? ( net-wireless/bluez )
- ffmpeg? ( virtual/ffmpeg )
- lzo? ( dev-libs/lzo )
- openal? ( media-libs/openal )
- opengl? ( virtual/opengl )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- "
-DEPEND="${RDEPEND}
- app-arch/zip
- media-gfx/nvidia-cg-toolkit
- media-libs/freetype
- media-libs/libsoundtouch
- >=sys-devel/gcc-4.6.0
- x11-libs/wxGTK:2.9
- "
-
-pkg_pretend() {
-
- local ver=4.6.0
- local msg="${PN} needs at least GCC ${ver} set to compile."
-
- if [[ ${MERGE_TYPE} != binary ]]; then
- if ! version_is_at_least ${ver} $(gcc-fullversion); then
- eerror ${msg}
- die ${msg}
- fi
- fi
-
-}
-
-src_prepare() {
-
- # Remove automatic dependencies to prevent building without flags enabled.
- if use !alsa; then
- sed -i -e '^/include(FindALSA/d' CMakeLists.txt || die
- fi
- if use !ao; then
- sed -i -e '/^check_lib(AO/d' CMakeLists.txt || die
- fi
- if use !bluetooth; then
- sed -i -e '/^check_lib(BLUEZ/d' CMakeLists.txt || die
- fi
- if use !openal; then
- sed -i -e '/^include(FindOpenAL/d' CMakeLists.txt || die
- fi
- if use !portaudio; then
- sed -i -e '/CMAKE_REQUIRED_LIBRARIES portaudio/d' CMakeLists.txt || die
- fi
- if use !pulseaudio; then
- sed -i -e '/^check_lib(PULSEAUDIO/d' CMakeLists.txt || die
- fi
-
- # Remove ALL the bundled libraries, aside from:
- # - SOIL: The sources are not public.
- # - Bochs-disasm: Don't know what it is.
- # - CLRun: Part of OpenCL
- # - polarssl: Currently fails the check as is.
- mv Externals/SOIL . || die
- mv Externals/Bochs_disasm . || die
- mv Externals/CLRun . || die
- mv Externals/polarssl . || die
- rm -r Externals/* || die
- mv polarssl Externals || die
- mv CLRun Externals || die
- mv Bochs_disasm Externals || die
- mv SOIL Externals || die
-
- # Add call for FindX11 as FindOpenGL does not include it implicitly
- # anymore for >=cmake-3.2. For more info, see:
- # https://public.kitware.com/Bug/print_bug_page.php?bug_id=15268
- if has_version ">=dev-util/cmake-3.2"; then
- sed -i -e '/if(NOT ANDROID)/a include(FindX11)' CMakeLists.txt || die
-
- # Fix syntax warnings in FindMiniupnpc.cmake
- sed -i -e 's/\"\"/\\\"\\\"/g' CMakeTests/FindMiniupnpc.cmake || die
- fi
-}
-
-src_configure() {
-
- local mycmakeargs=(
- "-DDOLPHIN_WC_REVISION=${PV}"
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-Dprefix=${GAMES_PREFIX}"
- "-Ddatadir=${GAMES_DATADIR}/${PN}"
- "-Dplugindir=$(games_get_libdir)/${PN}"
- $( cmake-utils_use ffmpeg ENCODE_FRAMEDUMPS )
- $( cmake-utils_use openmp OPENMP )
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
-
- cmake-utils_src_compile
-}
-
-src_install() {
-
- cmake-utils_src_install
-
- dodoc Readme.txt
- if use doc; then
- dodoc -r docs/ActionReplay docs/DSP docs/WiiMote
- fi
-
- doicon Source/Core/DolphinWX/resources/Dolphin.xpm
- make_desktop_entry "dolphin-emu" "Dolphin" "Dolphin" "Game;"
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- # Add pax markings for hardened systems
- pax-mark -m "${EPREFIX}"/usr/games/bin/"${PN}"-emu
-
- if ! use portaudio; then
- ewarn "If you want microphone capabilities in dolphin-emu, rebuild with"
- ewarn "USE=\"portaudio\""
- fi
-}
diff --git a/games-emulation/dolphin/dolphin-4.0.2-r7.ebuild b/games-emulation/dolphin/dolphin-4.0.2-r7.ebuild
deleted file mode 100644
index c85c5fc3a4e6..000000000000
--- a/games-emulation/dolphin/dolphin-4.0.2-r7.ebuild
+++ /dev/null
@@ -1,155 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-WX_GTK_VER="3.0"
-
-inherit cmake-utils eutils pax-utils toolchain-funcs versionator wxwidgets games
-
-SRC_URI="https://github.com/${PN}-emu/${PN}/archive/${PV}.zip -> ${P}.zip"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Gamecube and Wii game emulator"
-HOMEPAGE="https://www.dolphin-emu.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="alsa ao bluetooth doc ffmpeg +lzo openal opengl openmp portaudio pulseaudio"
-
-RESTRICT="mirror"
-
-RDEPEND=">=media-libs/glew-1.6
- <media-libs/libsfml-2.0
- >=net-libs/miniupnpc-1.8
- media-libs/libsdl2[haptic,joystick]
- sys-libs/readline:=
- x11-libs/libXext
- x11-libs/libXrandr
- alsa? ( media-libs/alsa-lib )
- ao? ( media-libs/libao )
- bluetooth? ( net-wireless/bluez )
- ffmpeg? ( virtual/ffmpeg
- !!>=media-video/libav-10 )
- lzo? ( dev-libs/lzo )
- openal? ( media-libs/openal )
- opengl? ( virtual/opengl )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- "
-DEPEND="${RDEPEND}
- app-arch/zip
- media-gfx/nvidia-cg-toolkit
- media-libs/freetype
- media-libs/libsoundtouch
- >=sys-devel/gcc-4.6.0
- x11-libs/wxGTK:${WX_GTK_VER}
- "
-
-pkg_pretend() {
-
- local ver=4.6.0
- local msg="${PN} needs at least GCC ${ver} set to compile."
-
- if [[ ${MERGE_TYPE} != binary ]]; then
- if ! version_is_at_least ${ver} $(gcc-fullversion); then
- eerror ${msg}
- die ${msg}
- fi
- fi
-
-}
-
-src_prepare() {
-
- # Remove automatic dependencies to prevent building without flags enabled.
- if use !alsa; then
- sed -i -e '/include(FindALSA/d' CMakeLists.txt || die
- fi
- if use !ao; then
- sed -i -e '/check_lib(AO/d' CMakeLists.txt || die
- fi
- if use !bluetooth; then
- sed -i -e '/check_lib(BLUEZ/d' CMakeLists.txt || die
- fi
- if use !openal; then
- sed -i -e '/include(FindOpenAL/d' CMakeLists.txt || die
- fi
- if use !portaudio; then
- sed -i -e '/CMAKE_REQUIRED_LIBRARIES portaudio/d' CMakeLists.txt || die
- fi
- if use !pulseaudio; then
- sed -i -e '/check_lib(PULSEAUDIO/d' CMakeLists.txt || die
- fi
-
- # Remove ALL the bundled libraries, aside from:
- # - SOIL: The sources are not public.
- # - Bochs-disasm: Don't know what it is.
- # - CLRun: Part of OpenCL
- # - polarssl: Currently fails the check as is.
- mv Externals/SOIL . || die
- mv Externals/Bochs_disasm . || die
- mv Externals/CLRun . || die
- mv Externals/polarssl . || die
- rm -r Externals/* || die
- mv polarssl Externals || die
- mv CLRun Externals || die
- mv Bochs_disasm Externals || die
- mv SOIL Externals || die
-
- # Add call for FindX11 as FindOpenGL does not include it implicitly
- # anymore for >=cmake-3.2. For more info, see:
- # https://public.kitware.com/Bug/print_bug_page.php?bug_id=15268
- if has_version ">=dev-util/cmake-3.2"; then
- sed -i -e '/if(NOT ANDROID)/a include(FindX11)' CMakeLists.txt || die
-
- # Fix syntax warnings in FindMiniupnpc.cmake
- sed -i -e 's/\"\"/\\\"\\\"/g' CMakeTests/FindMiniupnpc.cmake || die
- fi
-}
-
-src_configure() {
-
- local mycmakeargs=(
- "-DDOLPHIN_WC_REVISION=${PV}"
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-Dprefix=${GAMES_PREFIX}"
- "-Ddatadir=${GAMES_DATADIR}/${PN}"
- "-Dplugindir=$(games_get_libdir)/${PN}"
- $( cmake-utils_use ffmpeg ENCODE_FRAMEDUMPS )
- $( cmake-utils_use openmp OPENMP )
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
-
- cmake-utils_src_compile
-}
-
-src_install() {
-
- cmake-utils_src_install
-
- dodoc Readme.txt
- if use doc; then
- dodoc -r docs/ActionReplay docs/DSP docs/WiiMote
- fi
-
- doicon Source/Core/DolphinWX/resources/Dolphin.xpm
- make_desktop_entry "dolphin-emu" "Dolphin" "Dolphin" "Game;"
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- # Add pax markings for hardened systems
- pax-mark -m "${EPREFIX}"/usr/games/bin/"${PN}"-emu
-
- if ! use portaudio; then
- ewarn "If you want microphone capabilities in dolphin-emu, rebuild with"
- ewarn "USE=\"portaudio\""
- fi
-}