summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-emulation/fceux
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-emulation/fceux')
-rw-r--r--games-emulation/fceux/Manifest1
-rw-r--r--games-emulation/fceux/fceux-2.2.2.ebuild49
-rw-r--r--games-emulation/fceux/files/fceux-2.2.2-warnings.patch33
-rw-r--r--games-emulation/fceux/metadata.xml8
4 files changed, 91 insertions, 0 deletions
diff --git a/games-emulation/fceux/Manifest b/games-emulation/fceux/Manifest
new file mode 100644
index 000000000000..1db9abeaccb9
--- /dev/null
+++ b/games-emulation/fceux/Manifest
@@ -0,0 +1 @@
+DIST fceux-2.2.2.src.tar.gz 9249858 SHA256 804d11bdb4a195f3a580ce5d2d01be877582763378637e16186a22459f5fe5e1 SHA512 3d3b11c21232656492d962c21a93097f66e33fbd5adbbce6b771dc004393f30502c369eae83c23d988c7e447b4784740a10dfcb0811252854d4364c4b1face98 WHIRLPOOL 61d12dd5db761d31ae83dcfc3117538313910cf844e502457326503d966ac38ca69e7c90d696da991394dd67a0b115f2b0698c217b5a077ed1c3ec9649508ff8
diff --git a/games-emulation/fceux/fceux-2.2.2.ebuild b/games-emulation/fceux/fceux-2.2.2.ebuild
new file mode 100644
index 000000000000..0a3cbb5cd715
--- /dev/null
+++ b/games-emulation/fceux/fceux-2.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils scons-utils games
+
+DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
+HOMEPAGE="http://fceux.com/"
+SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gtk +lua +opengl"
+
+DEPEND="lua? ( dev-lang/lua:0 )
+ media-libs/libsdl[opengl?,video]
+ opengl? ( virtual/opengl )
+ gtk? ( x11-libs/gtk+:3 )
+ sys-libs/zlib[minizip]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-warnings.patch
+}
+
+src_compile() {
+ escons \
+ GTK=0 \
+ CREATE_AVI=1 \
+ SYSTEM_LUA=1 \
+ SYSTEM_MINIZIP=1 \
+ $(use_scons gtk GTK3) \
+ $(use_scons opengl OPENGL) \
+ $(use_scons lua LUA)
+}
+
+src_install() {
+ dogamesbin bin/fceux
+
+ doman documentation/fceux.6
+ docompress -x /usr/share/doc/${PF}/documentation /usr/share/doc/${PF}/fceux.chm
+ dodoc -r Authors changelog.txt TODO-SDL bin/fceux.chm documentation
+ rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
+ make_desktop_entry fceux FCEUX
+ doicon fceux.png
+ prepgamesdirs
+}
diff --git a/games-emulation/fceux/files/fceux-2.2.2-warnings.patch b/games-emulation/fceux/files/fceux-2.2.2-warnings.patch
new file mode 100644
index 000000000000..f0af4631abda
--- /dev/null
+++ b/games-emulation/fceux/files/fceux-2.2.2-warnings.patch
@@ -0,0 +1,33 @@
+diff -ru fceux-2.2.2.orig/src/input.cpp fceux-2.2.2/src/input.cpp
+--- fceux-2.2.2.orig/src/input.cpp 2013-06-15 15:44:11.000000000 -0400
++++ fceux-2.2.2/src/input.cpp 2014-12-31 01:32:46.302001912 -0500
+@@ -1161,7 +1161,7 @@
+ // FIXME this will always evaluate to true, should this be
+ // if (*lastSavestateMade...) to check if it holds a string or just
+ // a '\0'?
+- if (lastSavestateMade && (undoSS || redoSS))
++ if (*lastSavestateMade && (undoSS || redoSS))
+ SwapSaveState();
+ }
+
+diff -ru fceux-2.2.2.orig/src/state.cpp fceux-2.2.2/src/state.cpp
+--- fceux-2.2.2.orig/src/state.cpp 2013-09-18 19:03:59.000000000 -0400
++++ fceux-2.2.2/src/state.cpp 2014-12-31 01:33:11.453155054 -0500
+@@ -1048,7 +1048,7 @@
+ //Both files must exist
+ //--------------------------------------------------------------------------------------------
+
+- if (!lastSavestateMade)
++ if (!*lastSavestateMade)
+ {
+ FCEUI_DispMessage("Can't Undo",0);
+ FCEUI_printf("Undo savestate was attempted but unsuccessful because there was not a recently used savestate.\n");
+@@ -1153,7 +1153,7 @@
+ void RedoLoadState()
+ {
+ if (!redoLS) return;
+- if (lastLoadstateMade && redoLS)
++ if (*lastLoadstateMade && redoLS)
+ {
+ FCEUSS_Load(lastLoadstateMade);
+ FCEUI_printf("Redoing %s\n",lastLoadstateMade);
diff --git a/games-emulation/fceux/metadata.xml b/games-emulation/fceux/metadata.xml
new file mode 100644
index 000000000000..ee1fe81755b2
--- /dev/null
+++ b/games-emulation/fceux/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">fceultra</remote-id>
+ </upstream>
+</pkgmetadata>