summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/four-in-a-row
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/four-in-a-row')
-rw-r--r--games-board/four-in-a-row/Manifest2
-rw-r--r--games-board/four-in-a-row/four-in-a-row-3.14.2.ebuild33
-rw-r--r--games-board/four-in-a-row/four-in-a-row-3.16.2.ebuild29
-rw-r--r--games-board/four-in-a-row/metadata.xml5
4 files changed, 69 insertions, 0 deletions
diff --git a/games-board/four-in-a-row/Manifest b/games-board/four-in-a-row/Manifest
new file mode 100644
index 000000000000..773c4d4c86f2
--- /dev/null
+++ b/games-board/four-in-a-row/Manifest
@@ -0,0 +1,2 @@
+DIST four-in-a-row-3.14.2.tar.xz 1964984 SHA256 32138122d807657b5adb58cf093129587ad1ea057242946acb2168eb797fcb99 SHA512 f19901d866c16fa961dff174a5393b882bbcf6612b39df5501c3153f8e428e6b934cc5f24d7d8902bb0b2a7c86699e7e42fda3c1d39366a7ef932eb6f768c407 WHIRLPOOL 2a3cdd899e6f745c1498197d6542e511715cfd24f517d71920d83ac1f7126181f84460ad9255b847ccdc6f04117c3e118fd7590ec046532b625fb96e6292f3f8
+DIST four-in-a-row-3.16.2.tar.xz 1933500 SHA256 bf42edfed65c5d9614cdf54dac40d17d3b100b0f56bc047b7812f0bb3564a5ae SHA512 bbeda27f372e9466e46196141d4784124d2ca92628a459d5959b5463c9be55c305e968eb25376ceaa883252fef96ef7466aa20b87f838806c1a7d9c6c2881c7a WHIRLPOOL ae4eddd70a1584e3f9a0f194f515beea75356550444b05e0966b230b96f81bf9362083d6f389cb92d06a8a1c0bfa329cfba987b1748c43ac95eb91e892c3292d
diff --git a/games-board/four-in-a-row/four-in-a-row-3.14.2.ebuild b/games-board/four-in-a-row/four-in-a-row-3.14.2.ebuild
new file mode 100644
index 000000000000..61e2271e0b68
--- /dev/null
+++ b/games-board/four-in-a-row/four-in-a-row-3.14.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome-games
+
+DESCRIPTION="Make lines of the same color to win"
+HOMEPAGE="https://wiki.gnome.org/Apps/Four-in-a-row"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ >=gnome-base/librsvg-2.32
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/gtk+-3.13.2:3
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-util/appdata-tools
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome-games_src_configure APPDATA_VALIDATE=$(type -P true)
+}
diff --git a/games-board/four-in-a-row/four-in-a-row-3.16.2.ebuild b/games-board/four-in-a-row/four-in-a-row-3.16.2.ebuild
new file mode 100644
index 000000000000..115c3c7ee445
--- /dev/null
+++ b/games-board/four-in-a-row/four-in-a-row-3.16.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome-games
+
+DESCRIPTION="Make lines of the same color to win"
+HOMEPAGE="https://wiki.gnome.org/Apps/Four-in-a-row"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ >=gnome-base/librsvg-2.32
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/gtk+-3.13.2:3
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+"
diff --git a/games-board/four-in-a-row/metadata.xml b/games-board/four-in-a-row/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/games-board/four-in-a-row/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>