summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-28 04:03:04 +0000
committerSam James <sam@gentoo.org>2023-01-28 05:10:52 +0000
commitf7a47b020609f8fedaa6286396c94dcbe45ae966 (patch)
treeb4559d0886cb6f1c69631b2c0e3ad0aa3e87b4ef /games-action
parentsys-kernel/zen-sources: bump to latest release (diff)
downloadgentoo-f7a47b020609f8fedaa6286396c94dcbe45ae966.tar.gz
gentoo-f7a47b020609f8fedaa6286396c94dcbe45ae966.tar.bz2
gentoo-f7a47b020609f8fedaa6286396c94dcbe45ae966.zip
games-action/supertuxkart: make vulkan unconditional for now
Fixed in next release upstream. Closes: https://bugs.gentoo.org/892165 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/supertuxkart/metadata.xml1
-rw-r--r--games-action/supertuxkart/supertuxkart-1.4-r1.ebuild (renamed from games-action/supertuxkart/supertuxkart-1.4.ebuild)11
2 files changed, 6 insertions, 6 deletions
diff --git a/games-action/supertuxkart/metadata.xml b/games-action/supertuxkart/metadata.xml
index 2e74607fa408..28d5e6b38a19 100644
--- a/games-action/supertuxkart/metadata.xml
+++ b/games-action/supertuxkart/metadata.xml
@@ -9,7 +9,6 @@
<flag name="nettle">Use <pkg>dev-libs/nettle</pkg> crypto backend</flag>
<flag name="recorder">Enable recording with <pkg>media-libs/libopenglrecorder</pkg></flag>
<flag name="sqlite">Record IP bans, statistics in server mode with <pkg>dev-db/sqlite</pkg></flag>
- <flag name="vulkan">Enable support for Vulkan</flag>
<flag name="wiimote">Support for wiimote input devices</flag>
</use>
<upstream>
diff --git a/games-action/supertuxkart/supertuxkart-1.4.ebuild b/games-action/supertuxkart/supertuxkart-1.4-r1.ebuild
index 495e18a9ae69..8cf641688c37 100644
--- a/games-action/supertuxkart/supertuxkart-1.4.ebuild
+++ b/games-action/supertuxkart/supertuxkart-1.4-r1.ebuild
@@ -15,12 +15,14 @@ SRC_URI="
LICENSE="GPL-2 GPL-3 CC-BY-SA-3.0 CC-BY-SA-4.0 CC0-1.0 public-domain ZLIB"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="debug nettle recorder sqlite vulkan wiimote"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="debug nettle recorder sqlite wiimote"
-# Don't unbundle irrlicht and bullet
+# - Don't unbundle irrlicht and bullet
# both are modified and system versions will break the game
# https://sourceforge.net/p/irrlicht/feature-requests/138/
+# - For >1.4, restore USE=vulkan and make shaderc dep optional,
+# and pass -DNO_SHADERC to cmake.
RDEPEND="
dev-cpp/libmcpp
dev-libs/angelscript:=
@@ -31,6 +33,7 @@ RDEPEND="
media-libs/libsdl2[opengl,video]
media-libs/libvorbis
media-libs/openal
+ media-libs/shaderc
net-libs/enet:1.3=
net-misc/curl
sys-libs/zlib
@@ -39,7 +42,6 @@ RDEPEND="
!nettle? ( >=dev-libs/openssl-1.0.1d:= )
recorder? ( media-libs/libopenglrecorder )
sqlite? ( dev-db/sqlite:3 )
- vulkan? ( media-libs/shaderc )
wiimote? ( net-wireless/bluez )
"
DEPEND="${RDEPEND}"
@@ -67,7 +69,6 @@ src_configure() {
-DUSE_CRYPTO_OPENSSL=$(usex nettle no yes)
-DBUILD_RECORDER=$(usex recorder)
-DUSE_WIIUSE=$(usex wiimote)
- -DNO_SHADERC=$(usex !vulkan)
-DSTK_INSTALL_BINARY_DIR=bin
-DSTK_INSTALL_DATA_DIR=share/${PN}
-DBUILD_SHARED_LIBS=OFF # build bundled libsquish as static library