summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/phobiaii
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/phobiaii')
-rw-r--r--games-action/phobiaii/Manifest1
-rw-r--r--games-action/phobiaii/metadata.xml5
-rw-r--r--games-action/phobiaii/phobiaii-1.1.ebuild37
3 files changed, 43 insertions, 0 deletions
diff --git a/games-action/phobiaii/Manifest b/games-action/phobiaii/Manifest
new file mode 100644
index 000000000000..a32623e1c99b
--- /dev/null
+++ b/games-action/phobiaii/Manifest
@@ -0,0 +1 @@
+DIST linuxphobia-1.1-i386.tar.bz2 7709686 SHA256 f70b66a919d04e828d0c2e3e84f7e90659dd6891cbadfe66413298c5db7c87af SHA512 c8a799eb1e9b25781ef37487951b4213be29a60613bb2455df44e484e3553f153e5872aa97c70286eaf64ba78c621941318f702e5dc680a5442728866d2f7a1d WHIRLPOOL 42f23f89134e9635d217b3572ce85cfafecf2bacc759c0a938e1675e3ab6775be311e083df2409db4732c938a76af807e7659d130f79423c922aa2779f83d96c
diff --git a/games-action/phobiaii/metadata.xml b/games-action/phobiaii/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/phobiaii/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/phobiaii/phobiaii-1.1.ebuild b/games-action/phobiaii/phobiaii-1.1.ebuild
new file mode 100644
index 000000000000..5bc3aeca179d
--- /dev/null
+++ b/games-action/phobiaii/phobiaii-1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_P="linuxphobia-${PV}"
+DESCRIPTION="Just a moment ago, you were safe inside your ship, behind five inch armour"
+HOMEPAGE="http://www.lynxlabs.com/games/linuxphobia/index.html"
+SRC_URI="http://www.lynxlabs.com/games/linuxphobia/${MY_P}-i386.tar.bz2"
+
+LICENSE="freedist" #505612
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-libs/lib-compat
+ media-libs/sdl-mixer[abi_x86_32(-)]
+ media-libs/libsdl[abi_x86_32(-)]"
+
+S=${WORKDIR}/${MY_P}
+
+QA_PRESTRIPPED="opt/phobiaii/linuxphobia"
+QA_FLAGS_IGNORED="opt/phobiaii/linuxphobia"
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ games_make_wrapper phobiaII ./linuxphobia "${dir}"
+ newicon phobia2.ico ${PN}.ico
+ make_desktop_entry phobiaII "Phobia II" /usr/share/pixmaps/${PN}.ico
+ insinto "${dir}"
+ doins -r *
+ rm -rf "${D}/${dir}"/{*.desktop,*.sh,/pics/.xvpics}
+ fperms 750 "${dir}"/linuxphobia
+ prepgamesdirs
+}