summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-07-05 02:23:32 +0200
committerDavid Seifert <soap@gentoo.org>2020-07-05 02:23:32 +0200
commit79becd30b4adcd72606eb50b9b154d31aa791284 (patch)
treeba08fc996212e71d3e157be858e65f8827797b0a /games-action/koth/koth-0.8.0-r1.ebuild
parentgames-emulation/dgen-sdl: Call AM_PROG_AR (diff)
downloadgentoo-79becd30b4adcd72606eb50b9b154d31aa791284.tar.gz
gentoo-79becd30b4adcd72606eb50b9b154d31aa791284.tar.bz2
gentoo-79becd30b4adcd72606eb50b9b154d31aa791284.zip
games-action/koth: Fix build system
Closes: https://bugs.gentoo.org/724324 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-action/koth/koth-0.8.0-r1.ebuild')
-rw-r--r--games-action/koth/koth-0.8.0-r1.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/games-action/koth/koth-0.8.0-r1.ebuild b/games-action/koth/koth-0.8.0-r1.ebuild
index 988f9bf485dc..3030dcd88d94 100644
--- a/games-action/koth/koth-0.8.0-r1.ebuild
+++ b/games-action/koth/koth-0.8.0-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic
+EAPI=7
+
+inherit autotools
DESCRIPTION="Multiplayer, networked game of little tanks with really big weapons"
HOMEPAGE="http://www.nongnu.org/koth/"
@@ -11,26 +12,25 @@ SRC_URI="https://savannah.nongnu.org/download/${PN}/default.pkg/${PV}/${P}.tar.b
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~x86"
-IUSE=""
DEPEND="media-libs/libggi"
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}"/${PF}-gcc-3.4.patch
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-gcc.patch
)
src_prepare() {
default
- sed -i 's:-g -O2::' configure || die
- sed -i 's:(uint16):(uint16_t):' src/gfx.c src/gfx.h || die
- append-cflags -std=gnu89 # build with gcc5 (bug #570730)
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_install() {
- DOCS="AUTHORS ChangeLog NEWS README doc/*.txt" \
- default
- dodir /etc/koth
+ default
+ dodoc doc/*.txt
+
insinto /etc/koth
doins src/koth.cfg
}