summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-02 20:58:41 +0300
committerMichał Górny <mgorny@gentoo.org>2022-06-07 08:53:55 +0200
commita3d63cfb2a15aa2a422c98cb2441de1bda0c350f (patch)
tree51ae5378a9bce737b3b96d1e6c424c5059252820 /eclass/distutils-r1.eclass
parentpython-any-r1.eclass: use python_has_version in examples (diff)
downloadgentoo-a3d63cfb2a15aa2a422c98cb2441de1bda0c350f.tar.gz
gentoo-a3d63cfb2a15aa2a422c98cb2441de1bda0c350f.tar.bz2
gentoo-a3d63cfb2a15aa2a422c98cb2441de1bda0c350f.zip
distutils-r1.eclass: small docs format fixes
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass9
1 files changed, 6 insertions, 3 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 30f7d941f0d4..9536e5c466be 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -119,7 +119,7 @@ esac
# - sip - sipbuild backend
#
# - standalone - standalone build systems without external deps
-# (used for bootstrapping).
+# (used for bootstrapping).
#
# The variable needs to be set before the inherit line. The eclass
# adds appropriate build-time dependencies and verifies the value.
@@ -149,10 +149,10 @@ esac
# - rdepend -- add it to BDEPEND+RDEPEND (e.g. when using pkg_resources)
#
# - pyproject.toml -- use pyproject2setuptools to install a project
-# using pyproject.toml (flit, poetry...)
+# using pyproject.toml (flit, poetry...)
#
# - manual -- do not add the dependency and suppress the checks
-# (assumes you will take care of doing it correctly)
+# (assumes you will take care of doing it correctly)
#
# This variable is effective only if DISTUTILS_OPTIONAL is disabled.
# It is available only in non-PEP517 mode. It needs to be set before
@@ -628,8 +628,11 @@ distutils_enable_tests() {
# (if ${EPYTHON} is set; fallback 'python' otherwise).
#
# setup.py will be passed the following, in order:
+#
# 1. ${DISTUTILS_ARGS[@]}
+#
# 2. ${mydistutilsargs[@]} (deprecated)
+#
# 3. additional arguments passed to the esetup.py function.
#
# Please note that setup.py will respect defaults (unless overridden