summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-01-29 12:58:00 -0600
committerWilliam Hubbs <williamh@gentoo.org>2021-01-29 12:58:52 -0600
commite80f4a61c9de49a7a742ca1b65ce11f99dee0414 (patch)
treef1405e94a1575ed81740d08a8a35b627c4d9c3b0 /dev-vcs
parentsys-process/bpytop: Remove old (diff)
downloadgentoo-e80f4a61c9de49a7a742ca1b65ce11f99dee0414.tar.gz
gentoo-e80f4a61c9de49a7a742ca1b65ce11f99dee0414.tar.bz2
gentoo-e80f4a61c9de49a7a742ca1b65ce11f99dee0414.zip
dev-vcs/python-gitlab: 2.6.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/python-gitlab/Manifest1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
index f875efd54480..1a2836092164 100644
--- a/dev-vcs/python-gitlab/Manifest
+++ b/dev-vcs/python-gitlab/Manifest
@@ -1 +1,2 @@
DIST python-gitlab-2.5.0.tar.gz 148916 BLAKE2B f870833a01adac08b71dc402bc11ba9c1be19c920735faf04de9bfca3b1a154706da4bc0475437997e3b03d8c9a56977a6691df05b750d64a1f8b964ecd05612 SHA512 7382f9ea2388c6916f3c7e63df137d73f0fdfb3890a8bbb47e766f3476b6febecd1dcbc588445ae1af1b5f17c9a3e6ed9a931fd9fff010c2c37967eab5440824
+DIST python-gitlab-2.6.0.tar.gz 153577 BLAKE2B 4fa0206faa601061fde257988362eca962c9e20f50e5ad57d602a76618581db646f26b035d4d86b9c460ef75f241fcbcdf360419b2e62ec6f95a664ab237d7d2 SHA512 b63dd4657b44fb484d114ceddc1d67465c17560978a8e6b09a9b14634ae6d80bf864b9b4583ddfc102c27c1082f4a015958c30944a734ec635761af524956fbe
diff --git a/dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild
new file mode 100644
index 000000000000..e395f7feed13
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-2.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND=">=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}