summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-05-24 19:33:49 +0800
committerYixun Lan <dlan@gentoo.org>2023-05-24 19:36:27 +0800
commit5bfeda2f76216af82500b6dcbaffc7dd8f1a835c (patch)
tree72574d4760d6ef6b0423585d4203d35e673c4b76 /dev-vcs
parentdev-util/blueprint-compiler: add libadwaita test dep (diff)
downloadgentoo-5bfeda2f76216af82500b6dcbaffc7dd8f1a835c.tar.gz
gentoo-5bfeda2f76216af82500b6dcbaffc7dd8f1a835c.tar.bz2
gentoo-5bfeda2f76216af82500b6dcbaffc7dd8f1a835c.zip
dev-vcs/git-pw: add 2.5.0
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-pw/Manifest1
-rw-r--r--dev-vcs/git-pw/git-pw-2.5.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-vcs/git-pw/Manifest b/dev-vcs/git-pw/Manifest
index 2db8f699d829..cd539f9d7ac9 100644
--- a/dev-vcs/git-pw/Manifest
+++ b/dev-vcs/git-pw/Manifest
@@ -1 +1,2 @@
DIST git-pw-2.4.0.tar.gz 34874 BLAKE2B cc44b3e8660e8ede70a32b2e7d79dc000c050a7359b9d092df535bb0d79f79dc6c95f2b8563e7f750cc74618530db376a1dee08802bc1f2f4b7239b1f4fe57c3 SHA512 5a2b22d33903c779d319a40afbce8f7137272d5fcd4ebd62901b59468333523aea3c276b56cc7227d4aa2b53c30664ac07858bab2f80ef99a55a28af0feecefb
+DIST git-pw-2.5.0.tar.gz 35380 BLAKE2B 18b8e7eab4140b2e1010fb346e9dd3f39cf0c0b8d750c596590ecdb2693e8721834917680664ae166092addb6ea9d3bd67dc3060db7773ca488a8f714cfa248e SHA512 46d44187b4d5dd87b484461fa00fa805c475f32f40d2cb05fa3cdbeebd83f04636082af23e5cba7b07ecb89ad4ff81470da9b8fef3dccd50fbdcca48483c82e8
diff --git a/dev-vcs/git-pw/git-pw-2.5.0.ebuild b/dev-vcs/git-pw/git-pw-2.5.0.ebuild
new file mode 100644
index 000000000000..b6ff46dff532
--- /dev/null
+++ b/dev-vcs/git-pw/git-pw-2.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/getpatchwork/git-pw.git"
+else
+ SRC_URI="https://github.com/getpatchwork/git-pw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool for integrating Git with Patchwork"
+HOMEPAGE="https://github.com/getpatchwork/git-pw"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/arrow-0.10[${PYTHON_USEDEP}]
+ >=dev-python/click-6.0[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/mock-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.5[${PYTHON_USEDEP}]
+ )
+"
+
+src_compile() {
+ export PBR_VERSION=${PV}
+ distutils-r1_src_compile
+}
+distutils_enable_tests pytest