summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-05-21 12:19:12 +0100
committerMarek Szuba <marecki@gentoo.org>2023-05-21 12:19:12 +0100
commit3002d018f911426b7894f906b65ad4a515626f27 (patch)
tree2b3e11b8fbb0de4a45882315ce9e39e90dab2a62 /dev-vcs
parentdev-python/pyopencl: add 2023.1 (diff)
downloadgentoo-3002d018f911426b7894f906b65ad4a515626f27.tar.gz
gentoo-3002d018f911426b7894f906b65ad4a515626f27.tar.bz2
gentoo-3002d018f911426b7894f906b65ad4a515626f27.zip
dev-vcs/pre-commit: add 3.3.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/pre-commit/Manifest1
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.3.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 569145bf615f..166b1086344b 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,3 +1,4 @@
DIST pre-commit-3.0.4.gh.tar.gz 264952 BLAKE2B 3c45da675d5a1a1fc115db0ef7186c1ec1e5a6d6d9353c5a53dba85a14de2c94bafe0ef9e8d0b04bae55ded81890d726997e695c95889719096205e1b212a237 SHA512 d51aca29b50f67ae42aa70d849939e6af96ff64c6fb214cddbc5a35cacebb8a54a4911110d0615a1a499516fcc2a06bb47d7e11da84ef636c3fcfdc8d2cbe343
DIST pre-commit-3.2.1.gh.tar.gz 267233 BLAKE2B 39843fa9f7529ee38670b3c7ebea1e29b080db47ae3db73d5a218455fd51b7bf86bb1ab1a979946a57bf6417f8a4e7050e8ba34f873bf4d76fa49fa76358964e SHA512 5e2c114049d84eae2ec6cbf123c8e3976d8e9e392a6e04f78d446ad85758a78fb912c0f6070b9c506f8c1bb87e1fd1ecbe763deb8d1430e1d3d8f296dd0cc389
DIST pre-commit-3.2.2.gh.tar.gz 267269 BLAKE2B b3b245b2ac0f0f4012e2612515e376aaaf5b4de0b5494c02a2b38b1b9b8584ae3fa7d9ee482ee19bbf6eb5ac1d5f9ec187e44c4bb7bb6046488b178628af850e SHA512 bf2602508425482e57c2e1b1ca2b36085560fa0e51e5d559b6c715a0534f182897eb54831a17a60a713cea0301a7521bb75c03881e8cb8527fbc565259a23ddf
+DIST pre-commit-3.3.1.gh.tar.gz 267261 BLAKE2B d502f39b1766c865260c1c17ec3651ef6295efda28444b93e6f43e9ae1106488722eab09efd5936d12ec46a97d4e5faf420bfe599d17af0a129a032f76bc12c2 SHA512 c73a6718902f669ca3edb7bb93d40079275069958921e9dc7fa58b0861ed22d9e4b96ba9c39120e5e20c6c5689ca744fc4603c0f5a5dc26256b20682cc07e2a6
diff --git a/dev-vcs/pre-commit/pre-commit-3.3.1.ebuild b/dev-vcs/pre-commit/pre-commit-3.3.1.ebuild
new file mode 100644
index 000000000000..85138095ce63
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-3.3.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-vcs/git
+ $(python_gen_cond_dep '
+ >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
+ ')"
+# coreutils requirement: see Bug #885559
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+ sys-apps/coreutils[-multicall]
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-tests_git_file_transport.patch
+)
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
+# and while some of them do include "skip if not found" logic, most of them do not.
+# The latter consistently fail with
+# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
+# including with the sandbox disabled.
+EPYTEST_DESELECT=(
+ tests/languages/
+ tests/repository_test.py
+ tests/main_test.py::test_all_cmds
+ tests/main_test.py::test_hook_stage_migration
+ tests/main_test.py::test_try_repo
+)
+
+distutils_enable_tests pytest