summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/qgit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/qgit')
-rw-r--r--dev-vcs/qgit/Manifest1
-rw-r--r--dev-vcs/qgit/metadata.xml8
-rw-r--r--dev-vcs/qgit/qgit-2.5.ebuild30
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-vcs/qgit/Manifest b/dev-vcs/qgit/Manifest
new file mode 100644
index 000000000000..06b7d2dbd50d
--- /dev/null
+++ b/dev-vcs/qgit/Manifest
@@ -0,0 +1 @@
+DIST qgit-2.5.tar.gz 250855 SHA256 25f1ca2860d840d87b9919d34fc3a1b05d4163671ed87d29c3e4a8a09e0b2499 SHA512 1c56aa4019f3e7aeb4062f49bca48ff773ef0a9af9633e6ae58fe7bba441aa5d85bcdd2093954350d59bc6742b3440116b6e6d49c694a57cb1ffe70c89e4f94d WHIRLPOOL f312cb3ef6505aa61d6dbd8b07e7302047e73784042b29af7723b5a87c07e555d878a1173bee4b686c3c34059d61523d0caa1a3a8ae3b9aff947ec3b66d8f8fc
diff --git a/dev-vcs/qgit/metadata.xml b/dev-vcs/qgit/metadata.xml
new file mode 100644
index 000000000000..3c06801549f1
--- /dev/null
+++ b/dev-vcs/qgit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pesa@gentoo.org</email>
+ <name>Davide Pesavento</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-vcs/qgit/qgit-2.5.ebuild b/dev-vcs/qgit/qgit-2.5.ebuild
new file mode 100644
index 000000000000..44faeb7bb412
--- /dev/null
+++ b/dev-vcs/qgit/qgit-2.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Qt4 GUI for git repositories"
+HOMEPAGE="http://libre.tibirna.org/projects/qgit/wiki/QGit"
+SRC_URI="http://libre.tibirna.org/attachments/download/9/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND="${DEPEND}
+ >=dev-vcs/git-1.6
+"
+
+S=${WORKDIR}/redivivus
+
+src_install() {
+ newbin bin/qgit qgit4
+ newicon src/resources/qgit.png qgit4.png
+ make_desktop_entry qgit4 QGit qgit4
+ dodoc README
+}