summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-03-18 09:17:07 +0800
committerYixun Lan <dlan@gentoo.org>2021-03-19 11:41:31 +0800
commit3c39b091100eb0c3a56ef34b69a46fed0a16465e (patch)
tree07d8e9f65eeed9ee3beee5cedd875747f9335850 /dev-vcs/git-pw
parentdev-vcs/git-publish: add version 1.7.0 (diff)
downloadgentoo-3c39b091100eb0c3a56ef34b69a46fed0a16465e.tar.gz
gentoo-3c39b091100eb0c3a56ef34b69a46fed0a16465e.tar.bz2
gentoo-3c39b091100eb0c3a56ef34b69a46fed0a16465e.zip
dev-vcs/git-pw: add version 2.0.0
A handy tool to work with patchwork Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs/git-pw')
-rw-r--r--dev-vcs/git-pw/Manifest1
-rw-r--r--dev-vcs/git-pw/files/git-pw-2.0.0-version.patch11
-rw-r--r--dev-vcs/git-pw/git-pw-2.0.0.ebuild42
-rw-r--r--dev-vcs/git-pw/metadata.xml17
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-vcs/git-pw/Manifest b/dev-vcs/git-pw/Manifest
new file mode 100644
index 000000000000..9911bd4fe414
--- /dev/null
+++ b/dev-vcs/git-pw/Manifest
@@ -0,0 +1 @@
+DIST git-pw-2.0.0.tar.gz 32151 BLAKE2B f8ef04b31cb4457ac9bae333bae65deb7d17469cd25a3724a27201dab0c05f98151a5ec1066cb9d2de81d82360f4e46eaa59ebd08904dfa0d16106f589e17e4c SHA512 83ac4d56091bfe9b03733939fb3e4feab22ce4455eebe8508bc730705b69054a2f060cfb8a1ea469476d9519809a89116ff56210efe4cd76e50df5a5d40886fc
diff --git a/dev-vcs/git-pw/files/git-pw-2.0.0-version.patch b/dev-vcs/git-pw/files/git-pw-2.0.0-version.patch
new file mode 100644
index 000000000000..92706506c697
--- /dev/null
+++ b/dev-vcs/git-pw/files/git-pw-2.0.0-version.patch
@@ -0,0 +1,11 @@
+diff --git a/PKG-INFO b/PKG-INFO
+new file mode 100644
+index 0000000..9748ce5
+--- /dev/null
++++ b/PKG-INFO
+@@ -0,0 +1,5 @@
++Metadata-Version: 2.1
++Name: git-pw
++Version: 2.0.0
++Summary: A tool for integrating Git with Patchwork
++Home-page: https://github.com/getpatchwork/git-pw
diff --git a/dev-vcs/git-pw/git-pw-2.0.0.ebuild b/dev-vcs/git-pw/git-pw-2.0.0.ebuild
new file mode 100644
index 000000000000..8efc99b1623b
--- /dev/null
+++ b/dev-vcs/git-pw/git-pw-2.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/getpatchwork/git-pw.git"
+else
+ SRC_URI="https://github.com/getpatchwork/git-pw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool for integrating Git with Patchwork"
+HOMEPAGE="https://github.com/getpatchwork/git-pw"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/arrow-0.10[${PYTHON_USEDEP}]
+ <dev-python/click-8.0[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/mock-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/pytest-6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.5[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-version.patch" )
+
+distutils_enable_tests pytest
diff --git a/dev-vcs/git-pw/metadata.xml b/dev-vcs/git-pw/metadata.xml
new file mode 100644
index 000000000000..2845f37880c9
--- /dev/null
+++ b/dev-vcs/git-pw/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ git-pw is a tool for integrating Git with Patchwork, the web-based patch
+ tracking system. It only supports Patchwork 2.0+ and REST API support
+ must be enabled on the server end.
+ </longdescription>
+ <maintainer type="person">
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">getpatchwork/git-pw</remote-id>
+ </upstream>
+</pkgmetadata>