summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-05-11 12:35:41 +0100
committerMarek Szuba <marecki@gentoo.org>2023-05-11 12:59:31 +0100
commit4e7cf7c4d7b071bf9f7cb1203d17161b46b5e1ac (patch)
treece2873a30fb304c0712a578ed51a7d4c6ff01403 /dev-vcs/git-machete
parentdev-vcs/git-machete: drop 3.14.3, 3.16.1, 3.17.0 (diff)
downloadgentoo-4e7cf7c4d7b071bf9f7cb1203d17161b46b5e1ac.tar.gz
gentoo-4e7cf7c4d7b071bf9f7cb1203d17161b46b5e1ac.tar.bz2
gentoo-4e7cf7c4d7b071bf9f7cb1203d17161b46b5e1ac.zip
dev-vcs/git-machete: add 3.17.3
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs/git-machete')
-rw-r--r--dev-vcs/git-machete/Manifest1
-rw-r--r--dev-vcs/git-machete/git-machete-3.17.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/git-machete/Manifest b/dev-vcs/git-machete/Manifest
index f824b38dc39e..936417de8153 100644
--- a/dev-vcs/git-machete/Manifest
+++ b/dev-vcs/git-machete/Manifest
@@ -1 +1,2 @@
DIST git-machete-3.16.3.gh.tar.gz 1618456 BLAKE2B e8207b11bfea6dd50965aaa300ec7303684503b900912b031f08378c7d80b388b341d23769cea5fe4aef0d78bc8457b0118aa3e05a49b0c1c4a3f9a97019c46e SHA512 fcd856c0fefecd2cf97ba149f1d1df57eb6fab0345c00c3d3df763041cc86226e3f815dda7c0050f8669d7d082e329dd76304de2092c7b43219e0c50a2e3467a
+DIST git-machete-3.17.3.gh.tar.gz 1623473 BLAKE2B 57749f566f27086c6359a5ea08004bc2b84921c3bb42dfb7d9a2029b032cdf0626541ded8dc7af04ab821e187358e5a7ff6d789bf2e204a9f1ad4367939e3477 SHA512 bc138636e96f2fb415c28e6a429cc5a10de7b1edd22f752ce1f552fa33f16f668c5bc6917186f437ccf28fc2be15c8dc9cf21c3c9ec4ab49e5d63af5fee0f521
diff --git a/dev-vcs/git-machete/git-machete-3.17.3.ebuild b/dev-vcs/git-machete/git-machete-3.17.3.ebuild
new file mode 100644
index 000000000000..c04f32d1e272
--- /dev/null
+++ b/dev-vcs/git-machete/git-machete-3.17.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Probably the sharpest git repo organizer & rebase/merge workflow automation tool"
+HOMEPAGE="https://github.com/VirtusLab/git-machete https://pypi.org/project/git-machete/"
+# No tests in PyPI tarballs
+SRC_URI="https://github.com/VirtusLab/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="dev-vcs/git"
+BDEPEND="test? (
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.2.1[${PYTHON_USEDEP}]
+)"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ newbashcomp completion/${PN}.completion.bash ${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completion/${PN}.fish
+
+ insinto /usr/share/zsh/site-functions
+ newins completion/${PN}.completion.zsh _${PN}
+}