summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-30 22:33:34 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-31 00:09:29 +0100
commitf27e271ea2f7dd8ad6f71431c9e6ec94225ccfc1 (patch)
tree7638b6aa623216729cb775e9d40295f10037dbf0 /dev-util
parentdev-util/shards: drop old 0.17.3 (diff)
downloadgentoo-f27e271ea2f7dd8ad6f71431c9e6ec94225ccfc1.tar.gz
gentoo-f27e271ea2f7dd8ad6f71431c9e6ec94225ccfc1.tar.bz2
gentoo-f27e271ea2f7dd8ad6f71431c9e6ec94225ccfc1.zip
dev-util/shards: bump to 0.18.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/shards/Manifest1
-rw-r--r--dev-util/shards/shards-0.18.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/shards/Manifest b/dev-util/shards/Manifest
index 3181bb8fa3d4..e905d42a7e56 100644
--- a/dev-util/shards/Manifest
+++ b/dev-util/shards/Manifest
@@ -1,2 +1,3 @@
DIST crystal-molinillo-0.2.0.tar.gz 23959 BLAKE2B 257dcca66583db87a802b27b1f100e226eb0b6ac53708d110040d7b5560f429a82f11595e303af4922f22917d922d60ea380fb395d254dc3b3ce24f4183395b6 SHA512 7c00a6a3ee4864b712ad8b703557f10498ba0b25491a55ae2f6c02d574034ec5bf8b87df777c3d34eb9cc4c87eebdcf6567c153e9edf3bc3c1b9ac4306ce3dc2
DIST shards-0.17.4.tar.gz 73231 BLAKE2B 8480d6a56fadf1dfac44262fe260365f910ba8004f2361cae5646c2fa77a0e71c46b91c9a707e7b3825ed94a31eb94dc43d16b6d7e1da5efcc52a22ea39a51bb SHA512 82c7f2e4bb9b280a49cfb1a0468b2fe0a551d55b91b74e01d50478ff3b2652b872b225a345f8f7816f5130141603baad96387df2b0df45e7ec79c2d47956c011
+DIST shards-0.18.0.tar.gz 79910 BLAKE2B 8ca2a79d89f5eb7202a8f86d39817a5d60bababbcc7a02450b30d0e0923b6e6e07db0accdc53b7de1fb9f238db797f8b6737f195666abaae5d208b884c0e86c0 SHA512 99f325792ab13bb1301e29b5b9cc09b10bb081c85d5f67e1a2d9dddd9b1118e23048630ffb7a8a740924b119f774cf22a8f3f223338a82a5c242460bb68f2eb7
diff --git a/dev-util/shards/shards-0.18.0.ebuild b/dev-util/shards/shards-0.18.0.ebuild
new file mode 100644
index 000000000000..0f0cbfd373dc
--- /dev/null
+++ b/dev-util/shards/shards-0.18.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing toolchain-funcs
+
+CRYSTAL_MOLINILLO_PV="0.2.0"
+CRYSTAL_MOLINILLO_P="crystal-molinillo-${CRYSTAL_MOLINILLO_PV}"
+
+DESCRIPTION="Dependency manager for the Crystal language"
+HOMEPAGE="https://github.com/crystal-lang/shards/"
+SRC_URI="
+ https://github.com/crystal-lang/shards/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://github.com/crystal-lang/crystal-molinillo/archive/v${CRYSTAL_MOLINILLO_PV}.tar.gz
+ -> ${CRYSTAL_MOLINILLO_P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # Missing files in the tarball.
+
+RDEPEND="
+ >dev-lang/crystal-0.11.1
+ dev-libs/libyaml:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( CHANGELOG.md README.md SPEC.md )
+
+QA_PREBUILT=".*" # Generated by Crystal.
+
+src_prepare() {
+ default
+
+ # bundle crystal-molinillo to bootstrap 'shards'
+ mkdir -p lib || die
+ ln -s "../../${CRYSTAL_MOLINILLO_P}" lib/molinillo || die
+
+ tc-export CC
+}
+
+src_compile() {
+ emake release=1 \
+ FLAGS="--link-flags=\"${LDFLAGS}\" --verbose --threads $(makeopts_jobs)"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe "bin/${PN}"
+
+ doman man/*
+ einstalldocs
+}