summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-09-27 21:26:41 +0300
committerStefan Strogin <steils@gentoo.org>2019-09-27 21:37:25 +0300
commitab0e1c4306a0295c2190b423d59951a0b33ff91c (patch)
tree4204e0f6a8e1e2ff7cebdb77175b2c80b9f5bb67 /dev-util
parentdev-texlive/texlive-humanities: Drop old blockers (diff)
downloadgentoo-ab0e1c4306a0295c2190b423d59951a0b33ff91c.tar.gz
gentoo-ab0e1c4306a0295c2190b423d59951a0b33ff91c.tar.bz2
gentoo-ab0e1c4306a0295c2190b423d59951a0b33ff91c.zip
dev-util/bam: bump version to 0.5.1
Closes: https://bugs.gentoo.org/695746 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bam/Manifest1
-rw-r--r--dev-util/bam/bam-0.5.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/bam/Manifest b/dev-util/bam/Manifest
index 8061e8f111c6..0bb431c913a3 100644
--- a/dev-util/bam/Manifest
+++ b/dev-util/bam/Manifest
@@ -1 +1,2 @@
DIST bam-0.4.0.tar.bz2 164033 BLAKE2B 75c3ccc2c0a22e793ebaf116257ad735db097870b84dd3cb7e9c12068e97b38ae2317c148f04b3d9b45e39a415e595d519d003c6c58af1230ab066538f93e2de SHA512 10ba53b05ac1604a9e9a01f4c008a8cbdc4e4e9df2fc039c8ca59251461e4c5f95770b5b72945d07693db7abe7cd312bc38725686b4d509d5dc21a585fffc810
+DIST bam-0.5.1.tar.gz 258693 BLAKE2B 145016bc9da49942c53d27d191f55d6118343dec725477b494a221fb40050ab165a301c743071bbda294720c481830c223b688d6f214ce8764fc6ad2daea9b68 SHA512 e6f1b3daad6073c58b0e3cbf836bb0a6b66f0c36532d6e6eca9949239ab8b584cc88f892cce6f74974e370a8a688f33a95dde86dd65cc1790e49e5f8aeab0fef
diff --git a/dev-util/bam/bam-0.5.1.ebuild b/dev-util/bam/bam-0.5.1.ebuild
new file mode 100644
index 000000000000..7684f85a3ebf
--- /dev/null
+++ b/dev-util/bam/bam-0.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1 toolchain-funcs
+
+DESCRIPTION="Fast and flexible Lua-based build system"
+HOMEPAGE="https://matricks.github.com/bam/"
+SRC_URI="https://github.com/matricks/bam/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-lang/lua-5.3:="
+DEPEND="${RDEPEND}"
+BDEPEND="doc? (
+ ${PYTHON_DEPS}
+ media-gfx/graphviz
+ )
+ test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ if use doc || use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ # There is no such file licence.txt
+ sed -e '/license\.txt/d' -i scripts/gendocs.py || die
+ tc-export CC
+}
+
+src_compile() {
+ emake ${PN}
+ if use doc; then
+ "${EPYTHON}" scripts/gendocs.py || die "doc generation failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+ if use doc; then
+ dodoc docs/${PN}{.html,_logo.png}
+ fi
+}