summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-04-13 10:02:16 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-04-13 10:02:31 -0500
commit6c202db6b69ba6a7a95b327d4b89e9b9f6f8bd73 (patch)
tree506225bd24e136d854848f6fc3bf6ea45a807356 /dev-util
parentapp-misc/spire: add 1.6.2 (diff)
downloadgentoo-6c202db6b69ba6a7a95b327d4b89e9b9f6f8bd73.tar.gz
gentoo-6c202db6b69ba6a7a95b327d4b89e9b9f6f8bd73.tar.bz2
gentoo-6c202db6b69ba6a7a95b327d4b89e9b9f6f8bd73.zip
dev-util/github-cli: add 2.27.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/github-cli/Manifest2
-rw-r--r--dev-util/github-cli/github-cli-2.27.0.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-util/github-cli/Manifest b/dev-util/github-cli/Manifest
index 8453d29a7104..32bea17638b5 100644
--- a/dev-util/github-cli/Manifest
+++ b/dev-util/github-cli/Manifest
@@ -4,3 +4,5 @@ DIST github-cli-2.20.2-deps.tar.xz 105896704 BLAKE2B c9562daa3dc682b4733d4a6b716
DIST github-cli-2.20.2.tar.gz 759883 BLAKE2B a227ffc039ce861b0e006679f5487c5d9016cb57fc90438e29cccfcce6b087534ca7f53858c492296f35d721b802639d8b0100cf9c04166162e2f207a35c856b SHA512 2e14c408c2fbf5a409e7a271b5c77400cc84cd7f2567722fe7140f685ecd297dd39062d02d3fafaf9fa396da419fb7aa0c2d93c0541a30f3286c6745c5965df4
DIST github-cli-2.21.2-deps.tar.xz 105943376 BLAKE2B 88b2f6a74a5bd88bfab180531c275f210ec153a5accc07a5a22889151ce373feab4cdd50db0677fa3208de43e89b646327722b50fe5d87194f0a13b97cda8c9b SHA512 4bd39a91b33f4c8898e69901d1657dfd93a6889c51bd8f1c6107517e6280bd77e86a3afcff406480ef2e0625fb2c41b37fb8abb9bafdb35d306c50d9e40c63d6
DIST github-cli-2.21.2.tar.gz 774307 BLAKE2B 8f50d2cf5b093311974bffb56c0055021c35bf14f9323af0baaf5bc5803340ea053f7ae3cb5fe6475820c4e59a0044b55e865a87763be0cf65f7bb58ea9f5196 SHA512 c2bf99cfabae8329c6c0114afb2b7aadc6b081a0fa2398452c452f97e393f3597a61aa354223fad4f4a848089ee42dc26a529a43fc7006ffae090dadcb18c2e7
+DIST github-cli-2.27.0-deps.tar.xz 106343228 BLAKE2B ac99c816089dd7cc309dcb0984d87477e8b733ce938ac4b75c86357d63145ed4d4635d8c344fb68c806241636c7a84da372e228d8c074ad08b695c266b5c83ec SHA512 caa52b8c4216f2cde4bfd33df3240b79401e91574061d6417cf78c8049e617996aa20b6dd09aa7ab8e7f9f5ebaa55b2f997da47d153d95e6d413707c1a7fc3c3
+DIST github-cli-2.27.0.tar.gz 828409 BLAKE2B 1c543dbf8caf39198107a71bcde159996e6a333c9a0949d4a8862e72255246d558e72e35e13947bbc4a3122a101a623c45681c6ddf127d1f4a425b7ff03ad3d6 SHA512 ea475e828ac28dca3ba5a12a5340df697c4dad2d76140eb591b822e438a78511d82e4786b6949fb52396d8b1ef07d70b7d0b2a5a378785cf4b35d084829d1bea
diff --git a/dev-util/github-cli/github-cli-2.27.0.ebuild b/dev-util/github-cli/github-cli-2.27.0.ebuild
new file mode 100644
index 000000000000..afe949aebe68
--- /dev/null
+++ b/dev-util/github-cli/github-cli-2.27.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit bash-completion-r1 flag-o-matic go-module
+
+DESCRIPTION="GitHub CLI"
+HOMEPAGE="https://github.com/cli/cli"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cli/cli.git"
+else
+ SRC_URI="https://github.com/cli/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv"
+ S="${WORKDIR}/cli-${PV}"
+fi
+
+LICENSE="MIT Apache-2.0 BSD BSD-2 MPL-2.0"
+SLOT="0"
+
+RDEPEND=">=dev-vcs/git-1.7.3"
+
+RESTRICT="test"
+
+src_unpack() {
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ go-module_src_unpack
+ fi
+}
+
+src_compile() {
+ [[ ${PV} == *9999 ]] || export GH_VERSION="v${PV}"
+ # Filter '-flto*' flags to avoid build failures.
+ filter-flags "-flto*"
+ # Filter '-ggdb3' flag to avoid build failures. bugs.gentoo.org/847991
+ filter-flags "-ggdb3"
+ # Go LDFLAGS are not the same as GCC/Binutils LDFLAGS
+ unset LDFLAGS
+ # Once we set up cross compiling, this line will need to be adjusted
+ # to compile for the target.
+ # Everything else in this function happens on the host.
+ emake
+
+ einfo "Building man pages"
+ emake manpages
+
+ einfo "Building completions"
+ go run ./cmd/gh completion -s bash > gh.bash-completion || die
+ go run ./cmd/gh completion -s zsh > gh.zsh-completion || die
+}
+
+src_install() {
+ dobin bin/gh
+ dodoc README.md
+
+ doman share/man/man?/gh*.?
+
+ newbashcomp gh.bash-completion gh
+ insinto /usr/share/zsh/site-functions
+ newins gh.zsh-completion _gh
+}