summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 11:10:49 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 13:25:34 +0200
commit13772cc14e6f3ce53a1a3f687c7f6db899c825a6 (patch)
tree94df5c41cbab023d22605c6e7602d23969009b36 /dev-util/wstool
parentdev-python/vcstools: Bump to 0.1.38. (diff)
downloadgentoo-13772cc14e6f3ce53a1a3f687c7f6db899c825a6.tar.gz
gentoo-13772cc14e6f3ce53a1a3f687c7f6db899c825a6.tar.bz2
gentoo-13772cc14e6f3ce53a1a3f687c7f6db899c825a6.zip
dev-util/wstool: Bump to 0.1.12.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-util/wstool')
-rw-r--r--dev-util/wstool/Manifest1
-rw-r--r--dev-util/wstool/wstool-0.1.12.ebuild62
-rw-r--r--dev-util/wstool/wstool-9999.ebuild2
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-util/wstool/Manifest b/dev-util/wstool/Manifest
index cbac4c0955d3..312d718bd1de 100644
--- a/dev-util/wstool/Manifest
+++ b/dev-util/wstool/Manifest
@@ -1 +1,2 @@
DIST wstool-0.1.10.tar.gz 73404 SHA256 2810f7f384b45bc653e006e0d473ed66a3ba88e237792a92955bc61fcef61b7c SHA512 8b5924844e8ff0ddcce3302b550493a9bbe525c7c7d7f5a23e49d4734649f50893ca0f2e5dbd05b20ee73d31666d61a4c3035e7d30e6053bfe8ff5c6aa9aafde WHIRLPOOL b9a6399e0dfb894685b7ed83210fe2920bdcfb2a426684829c65fec33b3963eb6cde3f7c35f9f16194306731bb366ba54ce48ba10805ff70c7eaf0a094d7f15c
+DIST wstool-0.1.12.tar.gz 74561 SHA256 4ca6c61d8f311f9167d4e5e3d9b4acafb0c3a7c7a76607779eed047d9f6c7145 SHA512 2d398d28eae33fac06faec3dc2aa6867b3715ae4d586efa8f8e47fdeec88335e144665cf3564272cdf5fedca6789075659db29b80ea94569d38a1bc9a7d1a3c0 WHIRLPOOL 99c2011a31cd601f3518b95f7b2a16fe878493e4d95dbf8a0ec2cc613c19ff931755705771402da2a2f4b1a44a444e95698958c988f280112629c02e0f7e0e11
diff --git a/dev-util/wstool/wstool-0.1.12.ebuild b/dev-util/wstool/wstool-0.1.12.ebuild
new file mode 100644
index 000000000000..d8ec14af3a9d
--- /dev/null
+++ b/dev-util/wstool/wstool-0.1.12.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/wstool"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Commands to manage several local SCM repositories for ROS"
+HOMEPAGE="http://wiki.ros.org/wstool"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ http://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+PATCHES=( "${FILESDIR}/prefix.patch" )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ nosetests --with-coverage --cover-package=wstool || die
+}
diff --git a/dev-util/wstool/wstool-9999.ebuild b/dev-util/wstool/wstool-9999.ebuild
index 962d9993ae9e..d8ec14af3a9d 100644
--- a/dev-util/wstool/wstool-9999.ebuild
+++ b/dev-util/wstool/wstool-9999.ebuild
@@ -31,7 +31,7 @@ IUSE="test"
RDEPEND="
dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/vcstools[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
dev-python/sphinx