summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 19:38:30 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:12:11 +0100
commit842f3de42d108daf3563de984953f27a5ac951db (patch)
tree5366d71f22ba8e5a2a354bf18d59e7b8bb00ecdf /dev-util/visual-regexp
parentgames-puzzle/groundhog: port to EAPI 7 (diff)
downloadgentoo-842f3de42d108daf3563de984953f27a5ac951db.tar.gz
gentoo-842f3de42d108daf3563de984953f27a5ac951db.tar.bz2
gentoo-842f3de42d108daf3563de984953f27a5ac951db.zip
dev-util/visual-regexp: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/visual-regexp')
-rw-r--r--dev-util/visual-regexp/visual-regexp-3.0-r1.ebuild22
-rw-r--r--dev-util/visual-regexp/visual-regexp-3.1.ebuild24
2 files changed, 20 insertions, 26 deletions
diff --git a/dev-util/visual-regexp/visual-regexp-3.0-r1.ebuild b/dev-util/visual-regexp/visual-regexp-3.0-r1.ebuild
index a9549602cd92..4277831ac548 100644
--- a/dev-util/visual-regexp/visual-regexp-3.0-r1.ebuild
+++ b/dev-util/visual-regexp/visual-regexp-3.0-r1.ebuild
@@ -1,33 +1,29 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit desktop epatch
+inherit desktop
DESCRIPTION="Type the regexp and visualize it on a sample of your choice"
HOMEPAGE="http://laurent.riesterer.free.fr/regexp/"
SRC_URI="
https://dev.gentoo.org/~jlec/distfiles/visualregexp-icon.png.tar
http://laurent.riesterer.free.fr/regexp/visual_regexp-${PV}.tar.gz"
+S="${WORKDIR}"/visual_regexp-${PV}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-DEPEND=""
RDEPEND=">=dev-lang/tk-8.3"
-S=${WORKDIR}/visual_regexp-${PV}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-wish-fix.patch \
- "${FILESDIR}"/${P}-help-font-fix.patch \
- "${FILESDIR}"/${P}-home-conf-fix.patch \
- "${FILESDIR}"/${P}-pattern-load-fix.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-wish-fix.patch
+ "${FILESDIR}"/${P}-help-font-fix.patch
+ "${FILESDIR}"/${P}-home-conf-fix.patch
+ "${FILESDIR}"/${P}-pattern-load-fix.patch
+)
src_install() {
dodoc README
diff --git a/dev-util/visual-regexp/visual-regexp-3.1.ebuild b/dev-util/visual-regexp/visual-regexp-3.1.ebuild
index 456230c04a7c..835dd195fbad 100644
--- a/dev-util/visual-regexp/visual-regexp-3.1.ebuild
+++ b/dev-util/visual-regexp/visual-regexp-3.1.ebuild
@@ -1,25 +1,30 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit desktop edos2unix epatch
+inherit desktop edos2unix
DESCRIPTION="Type the regexp and visualize it on a sample of your choice"
HOMEPAGE="http://laurent.riesterer.free.fr/regexp/"
SRC_URI="
https://dev.gentoo.org/~jlec/distfiles/visualregexp-icon.png.tar
http://laurent.riesterer.free.fr/regexp/visual_regexp-${PV}.tcl"
+S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-DEPEND=""
RDEPEND=">=dev-lang/tk-8.5"
-S="${WORKDIR}"
+PATCHES=(
+ "${FILESDIR}"/${P}-wish-fix.patch
+ "${FILESDIR}"/${P}-help-font-fix.patch
+ "${FILESDIR}"/${P}-make-regexp-fix.patch
+ "${FILESDIR}"/${PN}-3.0-home-conf-fix.patch
+ "${FILESDIR}"/${PN}-3.0-pattern-load-fix.patch
+)
src_unpack() {
# Manually copy the source file since unpack gets confused by things it can't unpack
@@ -32,14 +37,7 @@ src_prepare() {
# File comes with DOS newlines
edos2unix visual_regexp.tcl
- epatch \
- "${FILESDIR}/${P}-wish-fix.patch" \
- "${FILESDIR}/${P}-help-font-fix.patch" \
- "${FILESDIR}/${P}-make-regexp-fix.patch" \
- "${FILESDIR}/${PN}-3.0-home-conf-fix.patch" \
- "${FILESDIR}/${PN}-3.0-pattern-load-fix.patch"
-
- epatch_user
+ default
}
src_install() {