summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/txt2regex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/txt2regex')
-rw-r--r--dev-util/txt2regex/Manifest1
-rw-r--r--dev-util/txt2regex/files/txt2regex-0.8-disable-nls.patch20
-rw-r--r--dev-util/txt2regex/metadata.xml5
-rw-r--r--dev-util/txt2regex/txt2regex-0.8-r1.ebuild31
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/txt2regex/Manifest b/dev-util/txt2regex/Manifest
new file mode 100644
index 000000000000..eb7735edc1ee
--- /dev/null
+++ b/dev-util/txt2regex/Manifest
@@ -0,0 +1 @@
+DIST txt2regex-0.8.tgz 40514 SHA256 19a10fbcc144ab80d1998488be380e5c4b307101e2740491d9f90685a5c0fc8d SHA512 69d2a682471e3e35fbd0b2ad6f6ffab040803a17bda8082f3dd67baf3a03e7011cb20047940fb9403e180895a1258f720ca4d538187878c5989a1ec51168435f WHIRLPOOL adb6ba8975ea5159ea61a652e0aa0ae8f3661c07a26a65490a0656db35351e67a78557a05490fa783fa8be97cb01cbe33f1443eede1171f6f6877c632a0c94e0
diff --git a/dev-util/txt2regex/files/txt2regex-0.8-disable-nls.patch b/dev-util/txt2regex/files/txt2regex-0.8-disable-nls.patch
new file mode 100644
index 000000000000..107b1b823753
--- /dev/null
+++ b/dev-util/txt2regex/files/txt2regex-0.8-disable-nls.patch
@@ -0,0 +1,20 @@
+diff -ur txt2regex-0.8/Makefile txt2regex-0.8.nonls/Makefile
+--- txt2regex-0.8/Makefile 2004-09-28 16:04:55 -0500
++++ txt2regex-0.8.nonls/Makefile 2005-05-14 15:28:38 -0500
+@@ -80,15 +80,8 @@
+ rm -rf $(DISTDIR)
+
+ #TODO install man page and README
+-install: mo
+- @[ -d $(LOCALEDIR) ] || mkdir -p $(LOCALEDIR); \
++install:
+ [ -d $(BINDIR) ] || mkdir -p $(BINDIR); \
+- for pot in `cd $(PODIR) && ls *.mo`; do \
+- poti=`echo $$pot | sed 's/\.mo$$//'`; \
+- modir=$(LOCALEDIR)/$$poti/LC_MESSAGES; \
+- [ -d $$modir ] || mkdir -p $$modir; \
+- install -m644 $(PODIR)/$$pot $$modir/$(NAME).mo; \
+- done; \
+ sed -e '/^TEXTDOMAINDIR=/s,=.*,=$(LOCALEDIR),' \
+ -e '/^VERSION=/s/=.*/=$(VERSION)/' $(SHSKEL) > $(BINDIR)/$(NAME) && \
+ chmod +x $(BINDIR)/$(NAME) && \
diff --git a/dev-util/txt2regex/metadata.xml b/dev-util/txt2regex/metadata.xml
new file mode 100644
index 000000000000..80ac69d9c2f2
--- /dev/null
+++ b/dev-util/txt2regex/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>shell-tools</herd>
+</pkgmetadata>
diff --git a/dev-util/txt2regex/txt2regex-0.8-r1.ebuild b/dev-util/txt2regex/txt2regex-0.8-r1.ebuild
new file mode 100644
index 000000000000..ba29402f2966
--- /dev/null
+++ b/dev-util/txt2regex/txt2regex-0.8-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="A Regular Expression wizard that converts human sentences to regexs"
+HOMEPAGE="http://txt2regex.sourceforge.net/"
+SRC_URI="http://txt2regex.sourceforge.net/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~mips ~ppc sparc x86"
+IUSE="nls cjk"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND=">=app-shells/bash-2.04"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # See bug 93568
+ use nls || epatch "${FILESDIR}"/${P}-disable-nls.patch
+ use cjk && sed -i -e 's/\xa4/:+:/g' "${S}"/${P}.sh
+}
+
+src_install() {
+ einstall DESTDIR="${D}" MANDIR="${D}"/usr/share/man/man1 || die
+ dodoc Changelog NEWS README README.japanese TODO || die
+ newman txt2regex.man txt2regex.6 || die
+}