summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wrótniak <karol.wrotniak@droidsonroids.pl>2018-07-15 17:08:48 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-17 17:25:47 +0100
commita60d4a1cf3582f03f7cf83081c5d064fad038484 (patch)
treed6482a810df0015ad19b116ba78808a41e05ce72 /dev-util/stepman
parentdev-util/envman: new ebuild, version 1.2.0 (diff)
downloadgentoo-a60d4a1cf3582f03f7cf83081c5d064fad038484.tar.gz
gentoo-a60d4a1cf3582f03f7cf83081c5d064fad038484.tar.bz2
gentoo-a60d4a1cf3582f03f7cf83081c5d064fad038484.zip
dev-util/stepman: new ebuild, version 0.10.0
Closes: https://bugs.gentoo.org/661246 Closes: https://github.com/gentoo/gentoo/pull/9235
Diffstat (limited to 'dev-util/stepman')
-rw-r--r--dev-util/stepman/Manifest1
-rw-r--r--dev-util/stepman/metadata.xml20
-rw-r--r--dev-util/stepman/stepman-0.10.0.ebuild39
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/stepman/Manifest b/dev-util/stepman/Manifest
new file mode 100644
index 000000000000..b47330bf9fb3
--- /dev/null
+++ b/dev-util/stepman/Manifest
@@ -0,0 +1 @@
+DIST stepman-0.10.0.tar.gz 3054342 BLAKE2B 8d1d6fc8b4b85c79d535c6162a8b7c5ba15042b6a8334286cdf7ad5d498ee20abecaa1bb9ce9ffe5406891271e23a2e2554bea0b52bbf08df23a2154fdcb4da8 SHA512 1437d5c997e62a9da3beb666a15ac665e18300fad3668ee3acdae30307027bbf16c0d95f649a9a62c6203f3e09f9ec83525a23b3789f09c3707ff1937a7affbe
diff --git a/dev-util/stepman/metadata.xml b/dev-util/stepman/metadata.xml
new file mode 100644
index 000000000000..a84ba4077979
--- /dev/null
+++ b/dev-util/stepman/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>karol.wrotniak@droidsonroids.pl</email>
+ <name>Karol Wrótniak</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>Step collection manager for Bitrise CLI. Part of the Bitrise Continuous Integration, Delivery and Automations Stack, with envman and bitrise. For a nice &amp; quick intro you
+should check: https://www.bitrise.io/cli</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/bitrise-io/stepman/issues</bugs-to>
+ <changelog>https://github.com/bitrise-io/stepman/blob/master/CHANGELOG.md</changelog>
+ <doc>https://github.com/bitrise-io/stepman/blob/master/README.md</doc>
+ <remote-id type="github">bitrise-io/stepman</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/stepman/stepman-0.10.0.ebuild b/dev-util/stepman/stepman-0.10.0.ebuild
new file mode 100644
index 000000000000..4b0b891bc494
--- /dev/null
+++ b/dev-util/stepman/stepman-0.10.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_ON="github.com/bitrise-io"
+EGO_PN="${EGO_ON}/${PN}"
+
+DESCRIPTION="Step collection manager for Bitrise CLI."
+HOMEPAGE="https://www.bitrise.io/cli"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/src/${EGO_ON}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
+ mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/stepman" || die "Couldn't move sources to GOPATH"
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" go build -v -o bin/stepman || die "Couldn't compile stepman"
+}
+
+src_test() {
+ export INTEGRATION_TEST_BINARY_PATH="${S}/bin/stepman"
+ GOPATH="${WORKDIR}" go test -v ./_tests/integration/... || die "Integration tests failed"
+}
+
+src_install() {
+ dobin bin/stepman
+ dodoc README.md
+}