summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-08-27 14:01:03 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-08-27 14:03:03 +0200
commit8db0c98d5e0516311be91ff5941f5e20858d6c9d (patch)
treea74f8815f1b04eb492f7c12dfec1b23f7bc5641b /dev-util/lttng-modules
parentdev-util/lttng-tools: add 2.13.13 (diff)
downloadgentoo-8db0c98d5e0516311be91ff5941f5e20858d6c9d.tar.gz
gentoo-8db0c98d5e0516311be91ff5941f5e20858d6c9d.tar.bz2
gentoo-8db0c98d5e0516311be91ff5941f5e20858d6c9d.zip
dev-util/lttng-modules: add 2.13.14
Switch to upstream's build system for compilation. Drop empty IUSE. Use MODULES_KERNEL_MIN instead of custom pkg_pretend. Thanks to ionen for assisting with this. Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-util/lttng-modules')
-rw-r--r--dev-util/lttng-modules/Manifest1
-rw-r--r--dev-util/lttng-modules/lttng-modules-2.13.14.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/lttng-modules/Manifest b/dev-util/lttng-modules/Manifest
index aa7f7575e68b..8df51ce1e122 100644
--- a/dev-util/lttng-modules/Manifest
+++ b/dev-util/lttng-modules/Manifest
@@ -1,3 +1,4 @@
DIST lttng-modules-2.12.5.tar.bz2 317002 BLAKE2B 9f42f8641dca7ce55e7445495c747ce340919458a23b4d471998fe2a28dd26bc7dfa5edbccf0b11877176091dee0c4d63fdda919c03afc8dad3fcfb7e9529c33 SHA512 81524dac513384852555a6f5619dc10286a2f7d4e3032ee9ca33705e830ee3bc3dc8c96b89a9c09dd5df2bf29944e3e566d1ac1a6cd6be83718af9836e043991
DIST lttng-modules-2.12.8.tar.bz2 319450 BLAKE2B 0ce5c6675598c1a4b6fbc0dfaf51d36638f12fe2e07095c37a811db8d7ee65bb242164cf02b1854c27b6894f0b4c73867e8ee1b80dd007290e0db203ea429f9e SHA512 5918a54d08a12cec567cdad2909846ba529d5e665a3592a69384d9546f6f3e23e7975876fc11feaef65604d36889b0598b1cf7b5f2badb4e2b11b255a2e7ca99
DIST lttng-modules-2.13.10.tar.bz2 350692 BLAKE2B a7596586adb63e3d7cdd849b4e6a4812409749c7e84f081d5367f3d5393884f8ae3e945597500336befac14191e84179decfd5153dff6cdcaed2d041055c268e SHA512 21c21bc186c0cf8465e411fdeeb09ce9f11fc0499915abaa086a2143ddc69905805b83847dad7e7c54aef4e61a9fc5507af5f25e478b2edd387309c7ca525b6f
+DIST lttng-modules-2.13.14.tar.bz2 355555 BLAKE2B 477947e83daf4f838453d82292f73cb24030639b1394fa586271285e0d1604d8098b1869c5cdcf2a1f55f9916e98a2f2e0dd005ca2d17c76db5362e38a29e993 SHA512 521c19cbdfa8e6f9d06f1a06312aee201823e1a7d1987f3de5d9dae08163cc8b51daff1bcbcbe79261ed8ded7232857136e7d0d4ebc05a3380b7377d43c1ee38
diff --git a/dev-util/lttng-modules/lttng-modules-2.13.14.ebuild b/dev-util/lttng-modules/lttng-modules-2.13.14.ebuild
new file mode 100644
index 000000000000..573ff069809c
--- /dev/null
+++ b/dev-util/lttng-modules/lttng-modules-2.13.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Please bump the following packages together:
+# dev-util/lttng-modules
+# dev-util/lttng-tools
+# dev-util/lttng-ust
+
+inherit linux-mod-r1
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="LTTng Kernel Tracer Modules"
+HOMEPAGE="https://lttng.org"
+SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+S="${WORKDIR}/${MY_P}"
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+
+KEYWORDS="~amd64 ~x86"
+
+CONFIG_CHECK="MODULES KALLSYMS HIGH_RES_TIMERS TRACEPOINTS
+ ~HAVE_SYSCALL_TRACEPOINTS ~PERF_EVENTS ~EVENT_TRACING ~KPROBES KRETPROBES"
+MODULES_KERNEL_MIN=3.0
+
+src_compile() {
+ emake "${MODULES_MAKEARGS[@]}"
+}
+
+src_install() {
+ emake "${MODULES_MAKEARGS[@]}" INSTALL_MOD_PATH="${ED}" modules_install
+ modules_post_process
+
+ dodoc ChangeLog README.md
+}