summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-03-31 20:38:48 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-03-31 20:38:48 +0200
commit63190a5a336e4b3c23377e332888fa73b6a158c1 (patch)
treedd29bac374d90c9c959045f29ccaa27dbbbb4c15 /dev-util/hadolint/hadolint-1.6.1.ebuild
parentdev-haskell/language-docker: Version bump to 4.0.1 (diff)
downloadgentoo-63190a5a336e4b3c23377e332888fa73b6a158c1.tar.gz
gentoo-63190a5a336e4b3c23377e332888fa73b6a158c1.tar.bz2
gentoo-63190a5a336e4b3c23377e332888fa73b6a158c1.zip
dev-util/hadolint: Version bump to 1.6.1
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'dev-util/hadolint/hadolint-1.6.1.ebuild')
-rw-r--r--dev-util/hadolint/hadolint-1.6.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/hadolint/hadolint-1.6.1.ebuild b/dev-util/hadolint/hadolint-1.6.1.ebuild
new file mode 100644
index 000000000000..9a011ff9f34e
--- /dev/null
+++ b/dev-util/hadolint/hadolint-1.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.5
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Dockerfile Linter JavaScript API"
+HOMEPAGE="https://github.com/hadolint/hadolint"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/dlist:=[profile?]
+ >=dev-haskell/gitrev-1.3.1:=[profile?]
+ >=dev-haskell/language-docker-3.0.0:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ >=dev-haskell/parsec-3.1:=[profile?]
+ >=dev-haskell/split-0.2:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/yaml:=[profile?]
+ >=dev-lang/ghc-8.0.2:=
+ >=dev-util/shellcheck-0.4.7:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.2.0
+ test? ( dev-haskell/hspec
+ >=dev-haskell/hunit-1.2 )
+"
+
+src_prepare() {
+ default
+ sed -i -e "s/-static//" ${PN}.cabal || die
+}