summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/gource
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/gource')
-rw-r--r--dev-util/gource/Manifest3
-rw-r--r--dev-util/gource/gource-0.39.ebuild61
-rw-r--r--dev-util/gource/gource-0.40.ebuild62
-rw-r--r--dev-util/gource/gource-0.43.ebuild62
-rw-r--r--dev-util/gource/metadata.xml17
5 files changed, 205 insertions, 0 deletions
diff --git a/dev-util/gource/Manifest b/dev-util/gource/Manifest
new file mode 100644
index 000000000000..23de2233dfcd
--- /dev/null
+++ b/dev-util/gource/Manifest
@@ -0,0 +1,3 @@
+DIST gource-0.39.tar.gz 856723 SHA256 0f97a3bad240ebc04e37ebbe8e0affaf8ad9bed997d90a4b59d05770c788ffeb SHA512 ff3e3ffb78e541c4aab542e2b0268e0008c9380743214b2726a95d88c7be07727535940c6225cdb7908c0dbf7b85565ee51fcc1d6f4244eef58b1efe68d2f7da WHIRLPOOL 5d8398be7bb543e0ced8cb8970c4e8e37aef23e2e999151f9371c2d4ece150c29d225c2e4d7adeefecffe98bf698e8353b77ae9b955317788fe2dcb0732251ec
+DIST gource-0.40.tar.gz 861731 SHA256 9c890a926bb3bab8ea3e546c1357488e5a5034d1ea9402afc654cb7e00ccd112 SHA512 f027a791674162a366ef30743508d841bc94b7b81c76041a8041d247420b76a9a82581793cb61e571da4805b2989a11e02dfd1246fe656115fef5568f283802a WHIRLPOOL f668854dc43fcc6776ffddc7582491b08744997a5c7a70ab59a5ca5019cc582ac3cbce7d041baa3fec41f78fed6f832cc803e0aea53b9a70cfb4f01f3ddb0bce
+DIST gource-0.43.tar.gz 874141 SHA256 85a40ac8e4f5c277764216465c248d6b76589ceac012541c4cc03883a24abde4 SHA512 4983c8afc534280ea61f9d1e0db2479f351acd349b62c2afd0c059faba0a73e1cebfb7d5e97ee6183461c7079df5a8126813f851cceb9cfa60ef23784e9152bd WHIRLPOOL b98c73f9b9bd73f49c459a28b1a75f00af696f26a3e202a7ee5fec09ea59132a77e07d9673ca1d04acc138e8bed53833bf93b5eaa4a1d250bf120c9de5480125
diff --git a/dev-util/gource/gource-0.39.ebuild b/dev-util/gource/gource-0.39.ebuild
new file mode 100644
index 000000000000..3b9f0c49df3b
--- /dev/null
+++ b/dev-util/gource/gource-0.39.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic versionator
+
+MY_P=${P/_p/-}
+MY_P=${MY_P/_/-}
+MY_DATE=${PV/*_p}
+
+DESCRIPTION="A software version control visualization tool"
+HOMEPAGE="http://code.google.com/p/gource/"
+SRC_URI="http://gource.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/boost-1.46:=[threads(+)]
+ >=media-libs/glew-1.5
+ >=media-libs/libpng-1.2
+ >=media-libs/libsdl-1.2.10[video,opengl,X]
+ >=media-libs/sdl-image-1.2[jpeg,png]
+ dev-libs/libpcre:3
+ dev-libs/tinyxml
+ media-fonts/freefont
+ media-libs/freetype:2
+ media-libs/mesa
+ virtual/glu
+ virtual/jpeg
+ "
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ >=media-libs/glm-0.9.3
+ "
+
+case ${PV} in
+ *_beta*)
+ my_v=$(get_version_component_range 1-3)
+ my_v=${my_v//_/-}
+ S="${WORKDIR}/${PN}-${my_v}" ;;
+ *)
+ S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)" ;;
+esac
+
+src_configure() {
+ # fix bug #386525
+ # this enable gource to be compiled against dev-libs/tinyxml[stl]
+ if has_version dev-libs/tinyxml[stl]; then
+ append-cppflags -DTIXML_USE_STL;
+ fi
+ econf --enable-ttf-font-dir=/usr/share/fonts/freefont/ \
+ --with-tinyxml
+}
+
+DOCS=( README ChangeLog THANKS )
diff --git a/dev-util/gource/gource-0.40.ebuild b/dev-util/gource/gource-0.40.ebuild
new file mode 100644
index 000000000000..94d9704e7154
--- /dev/null
+++ b/dev-util/gource/gource-0.40.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic versionator
+
+MY_P=${P/_p/-}
+MY_P=${MY_P/_/-}
+MY_DATE=${PV/*_p}
+
+DESCRIPTION="A software version control visualization tool"
+HOMEPAGE="http://code.google.com/p/gource/"
+SRC_URI="http://gource.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/boost-1.46:=[threads(+)]
+ >=media-libs/glew-1.5
+ >=media-libs/libpng-1.2
+ <media-libs/libsdl-2[video,opengl,X]
+ <media-libs/sdl-image-2[jpeg,png]
+ dev-libs/libpcre:3
+ dev-libs/tinyxml
+ media-fonts/freefont
+ media-libs/freetype:2
+ media-libs/mesa
+ virtual/glu
+ virtual/jpeg
+ "
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ >=media-libs/glm-0.9.3
+ "
+
+case ${PV} in
+ *_beta*)
+ my_v=$(get_version_component_range 1-3)
+ my_v=${my_v//_/-}
+ S="${WORKDIR}/${PN}-${my_v}" ;;
+ *)
+ S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)" ;;
+esac
+
+src_configure() {
+ # fix bug #386525
+ # this enable gource to be compiled against dev-libs/tinyxml[stl]
+ if has_version dev-libs/tinyxml[stl]; then
+ append-cppflags -DTIXML_USE_STL;
+ fi
+ econf \
+ --enable-ttf-font-dir=/usr/share/fonts/freefont/ \
+ --with-tinyxml
+}
+
+DOCS=( README ChangeLog THANKS )
diff --git a/dev-util/gource/gource-0.43.ebuild b/dev-util/gource/gource-0.43.ebuild
new file mode 100644
index 000000000000..a4b4c28dd28f
--- /dev/null
+++ b/dev-util/gource/gource-0.43.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic versionator
+
+MY_P=${P/_p/-}
+MY_P=${MY_P/_/-}
+MY_DATE=${PV/*_p}
+
+DESCRIPTION="A software version control visualization tool"
+HOMEPAGE="http://code.google.com/p/gource/"
+SRC_URI="https://github.com/acaudwell/Gource/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/boost-1.46:=[threads(+)]
+ >=media-libs/glew-1.5
+ >=media-libs/libpng-1.2
+ media-libs/libsdl2[video,opengl,X]
+ media-libs/sdl2-image[jpeg,png]
+ dev-libs/libpcre:3
+ dev-libs/tinyxml
+ media-fonts/freefont
+ media-libs/freetype:2
+ media-libs/mesa
+ virtual/glu
+ virtual/jpeg
+ "
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ >=media-libs/glm-0.9.3
+ "
+
+case ${PV} in
+ *_beta*)
+ my_v=$(get_version_component_range 1-3)
+ my_v=${my_v//_/-}
+ S="${WORKDIR}/${PN}-${my_v}" ;;
+ *)
+ S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)" ;;
+esac
+
+src_configure() {
+ # fix bug #386525
+ # this enable gource to be compiled against dev-libs/tinyxml[stl]
+ if has_version dev-libs/tinyxml[stl]; then
+ append-cppflags -DTIXML_USE_STL;
+ fi
+ econf \
+ --enable-ttf-font-dir=/usr/share/fonts/freefont/ \
+ --with-tinyxml
+}
+
+DOCS=( README ChangeLog THANKS )
diff --git a/dev-util/gource/metadata.xml b/dev-util/gource/metadata.xml
new file mode 100644
index 000000000000..7775c15af392
--- /dev/null
+++ b/dev-util/gource/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>enrico.tagliavini@gmail.com</email>
+ <name>Enrico Tagliavini</name>
+ <description>Proxied co-maintainer</description>
+ </maintainer>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">gource</remote-id>
+ <remote-id type="github">acaudwell/Gource</remote-id>
+ </upstream>
+</pkgmetadata>