summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-10-13 10:54:06 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-10-13 11:27:03 -0500
commit212bc28f2b4089d85e1b84acfa669f79c5856d02 (patch)
tree042cc3b6daa945b932a387366d920d64edb6fc65 /dev-util/gitlab-runner
parentdev-libs/libclc: Add 18.0.0_pre20231013 snapshot (diff)
downloadgentoo-212bc28f2b4089d85e1b84acfa669f79c5856d02.tar.gz
gentoo-212bc28f2b4089d85e1b84acfa669f79c5856d02.tar.bz2
gentoo-212bc28f2b4089d85e1b84acfa669f79c5856d02.zip
dev-util/gitlab-runner: add 16.4.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-16.4.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 9465a5c8e446..97ef32848750 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-runner-16.3.1-deps.tar.xz 200544092 BLAKE2B 7bebd181ce6a47bee99098d1
DIST gitlab-runner-16.3.1.tar.bz2 1366408 BLAKE2B 99d8ce6d99f2916a8477f97c5529ffa9e847859987c89ddb7e7ab3d2249b48e5836549ce992c9f20a65cab2261ee63f5b6b1dd25198dffd84379ab8ecf6e2df3 SHA512 9f59fd9966b7619aee93f3ad16d6c9a7c81203b015798674f44f111c59ef4d3a320344dacbd020ff9385e1e9ee5aae1a931102c3d0297dd4df9bf2615eb4a357
DIST gitlab-runner-16.4.0-deps.tar.xz 218817844 BLAKE2B 2e23b00ec77138699575bf1b5674b7d29867b901932301677e6cebe2a050b06b23d096d96e841f8baca902deaddea6053064de8eee5b477ba967ac8abbc5a51d SHA512 96cf86020773bedf543e20dd7ca009b4769cbd074a08c4a092a7d4decbb9d6c5e72a944056dc2034ffeb9f58d00af11c25cd5c2ab5a91020092fae948e14e5d5
DIST gitlab-runner-16.4.0.tar.bz2 1371838 BLAKE2B f86aa2abc9ab92fa0dc3ef9814f2fa37624e33aaf9eb4b14269e4141e59c751fbf7e446366fa4cdbd55afdc5adc672247d45188bfbf6cdb8b089fac780066b96 SHA512 48b9bfa9daf29e72dfaad363e580f3b80b5fe1031b64dcc962fa4d8d6603e1f8b93298f3fb420160c772173b6cd89daf32a31c5a0b1d93651e3ba60f8628c530
+DIST gitlab-runner-16.4.1-deps.tar.xz 218819612 BLAKE2B 5f8e69d4ea8e99b86c123bb97a2ff093b0efc453cf711e36e0596987c05cba01c77190fc3777157d4f587e7f99a63ec5f48265bfea8f176c81d4ad7c907b1bcc SHA512 a9e726cbb6a7e31d4d8ddcc67c25eba4d2dd6631413693ab7b7df3a9ac66aa1f9dcc2fca3c95e685b259e409dbeb22b41b89efee292b8d8f95f75b398a16b9aa
+DIST gitlab-runner-16.4.1.tar.bz2 1371697 BLAKE2B d1b3b5636e764afa9a619dc9f6af66d4e0edf6e6e0d4e81c78d9b093f86101fe4421e646f264f5776070afbacef8f93de8f4cfbb65360b827ecf68d4d41359f7 SHA512 e12b2cea44295151b9783800837367e61e769d95012c7b3d633a23bd93b85db2f61ffbe4e04b9dcac7a7caabb6511ea956f880774aceeeea36236b11c36d56d3
diff --git a/dev-util/gitlab-runner/gitlab-runner-16.4.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-16.4.1.ebuild
new file mode 100644
index 000000000000..a181955c5c1b
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-16.4.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=d89a789a
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}