summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/dissembler
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/dissembler')
-rw-r--r--dev-util/dissembler/Manifest1
-rw-r--r--dev-util/dissembler/dissembler-0.9.ebuild32
-rw-r--r--dev-util/dissembler/files/dissembler-0.9-build.patch21
-rw-r--r--dev-util/dissembler/metadata.xml7
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/dissembler/Manifest b/dev-util/dissembler/Manifest
new file mode 100644
index 000000000000..56efafd8b112
--- /dev/null
+++ b/dev-util/dissembler/Manifest
@@ -0,0 +1 @@
+DIST dissembler_0.9.tgz 4479 SHA256 fb2a38fe28ea6586bcead0acf918963f051c940af3ab35995ab9e27c6c2e198a SHA512 b6c7e4f42bb41be4320afd5d83abf6a0f1bbb58927931348e8a4ed9ee40ab756baa383ba4a405be5475ab669e5a38947422a4f6a0db16851eb8e6eb9f71f1332 WHIRLPOOL ba8c888450feb1894f3ebc23b08433be8b40d18fc71d7d82301b6d0d9d77c7ef3ba60727c6f3ad7e71152f65d062b6f17c3fb65e489587654168a7abffc72510
diff --git a/dev-util/dissembler/dissembler-0.9.ebuild b/dev-util/dissembler/dissembler-0.9.ebuild
new file mode 100644
index 000000000000..3ee7d80333f7
--- /dev/null
+++ b/dev-util/dissembler/dissembler-0.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}_${PV}
+DESCRIPTION="polymorphs bytecode to a printable ASCII string"
+HOMEPAGE="http://www.phiral.com/research/dissembler.html"
+SRC_URI="http://www.phiral.com/research/${MY_P}.tgz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" ${PN} || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ dodoc ${PN}.txt
+}
diff --git a/dev-util/dissembler/files/dissembler-0.9-build.patch b/dev-util/dissembler/files/dissembler-0.9-build.patch
new file mode 100644
index 000000000000..019dfec20ad6
--- /dev/null
+++ b/dev-util/dissembler/files/dissembler-0.9-build.patch
@@ -0,0 +1,21 @@
+--- dissembler.c
++++ dissembler.c
+@@ -16,6 +16,9 @@
+
+ /* FOR EDUCATIONAL PURPOSES ONLY */
+
++#define _GNU_SOURCE
++#include <string.h>
++#include <unistd.h>
+ #include <stdio.h>
+ #include <sys/stat.h>
+ #include <ctype.h>
+@@ -217,7 +217,7 @@ freedom:
+ fprintf(fh, "P");
+ }
+ fprintf(fh,"\n");
+- if(fh != stdout) close(fh);
++ if(fh != stdout) fclose(fh);
+ free(mem-21);
+ }
+
diff --git a/dev-util/dissembler/metadata.xml b/dev-util/dissembler/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/dev-util/dissembler/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>