summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-03-26 21:49:24 -0400
committerCraig Andrews <candrews@gentoo.org>2018-03-26 21:51:24 -0400
commit8f03586a73a35d48799d53d255f64df028586eeb (patch)
tree1d003d8de81e23533bfa5db919a1dd0fd8ec519d /dev-util/clinfo/clinfo-2.2.18.03.26.ebuild
parentlxde-base/lxpanel: RDEPEND x11-libs/gdk-pixbuf[X] (diff)
downloadgentoo-8f03586a73a35d48799d53d255f64df028586eeb.tar.gz
gentoo-8f03586a73a35d48799d53d255f64df028586eeb.tar.bz2
gentoo-8f03586a73a35d48799d53d255f64df028586eeb.zip
dev-util/clinfo: 2.2.18.03.26 version bump
Add dependency on >=app-eselect/eselect-opencl-1.1.0-r4 to ensure the required opencl 2.0 headers are present. Closes: https://bugs.gentoo.org/650730 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-util/clinfo/clinfo-2.2.18.03.26.ebuild')
-rw-r--r--dev-util/clinfo/clinfo-2.2.18.03.26.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/clinfo/clinfo-2.2.18.03.26.ebuild b/dev-util/clinfo/clinfo-2.2.18.03.26.ebuild
new file mode 100644
index 000000000000..3d01e885bdad
--- /dev/null
+++ b/dev-util/clinfo/clinfo-2.2.18.03.26.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Oblomov/clinfo.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Oblomov/clinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool to display info about the system's OpenCL capabilities"
+HOMEPAGE="https://github.com/Oblomov/clinfo"
+LICENSE="CC0-1.0"
+SLOT="0"
+
+DEPEND=">=app-eselect/eselect-opencl-1.1.0-r4
+ virtual/opencl"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake MANDIR="${ED}"/usr/share/man PREFIX="${ED}"/usr install
+}