summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/cccc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/cccc')
-rw-r--r--dev-util/cccc/Manifest1
-rw-r--r--dev-util/cccc/cccc-3.1.4.ebuild39
-rw-r--r--dev-util/cccc/files/cccc-3.1.4-gcc-4.7.patch11
-rw-r--r--dev-util/cccc/files/cccc-3.1.4-unbundle-pccts.patch47
-rw-r--r--dev-util/cccc/metadata.xml12
5 files changed, 110 insertions, 0 deletions
diff --git a/dev-util/cccc/Manifest b/dev-util/cccc/Manifest
new file mode 100644
index 000000000000..6f70191c212e
--- /dev/null
+++ b/dev-util/cccc/Manifest
@@ -0,0 +1 @@
+DIST cccc-3.1.4.tar.gz 632007 SHA256 27b3eca9a83a66799332363a80cc4bcd6db9869eddbda1a59a25cdace3ff4dbf SHA512 54b8838e228cd435497bac1fd3f1fe3bf2043871fe1046dd80b4382b08a7b249009aa5b06d5318868bbded31c31b45ec705c70abf3969f02b9680c3adb72a231 WHIRLPOOL bc432ad8247bf2da146db7d7a58af1c7344f5701198d8d9da8bc6e0491aa18fa901e70bb009aceb0356dc52059959d0045c848ec8f3bfe30aeb09cff973e18e2
diff --git a/dev-util/cccc/cccc-3.1.4.ebuild b/dev-util/cccc/cccc-3.1.4.ebuild
new file mode 100644
index 000000000000..0385935adbda
--- /dev/null
+++ b/dev-util/cccc/cccc-3.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A code counter for C and C++"
+HOMEPAGE="http://cccc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
+
+ sed -i -e "/^CFLAGS/s|=|+=|" pccts/antlr/makefile
+ sed -i -e "/^CFLAGS/s|=|+=|" pccts/dlg/makefile
+ sed -i -e "/^CFLAGS/s|=|+=|" \
+ -e "/^LD_OFLAG/s|-o|-o |" \
+ -e "/^LDFLAGS/s|=|+=|" cccc/posixgcc.mak
+ #LD_OFLAG: ld on Darwin needs a space after -o
+}
+
+src_compile() {
+ emake CCC="$(tc-getCXX)" LD="$(tc-getCXX)" pccts
+ emake CCC="$(tc-getCXX)" LD="$(tc-getCXX)" cccc
+}
+
+src_install() {
+ dodoc readme.txt changes.txt
+ dohtml cccc/*.html
+ cd install || die
+ dodir /usr
+ emake -f install.mak INSTDIR="${ED}"/usr/bin
+}
diff --git a/dev-util/cccc/files/cccc-3.1.4-gcc-4.7.patch b/dev-util/cccc/files/cccc-3.1.4-gcc-4.7.patch
new file mode 100644
index 000000000000..dcbe7aa26b47
--- /dev/null
+++ b/dev-util/cccc/files/cccc-3.1.4-gcc-4.7.patch
@@ -0,0 +1,11 @@
+--- cccc/cccc_tbl.cc
++++ cccc/cccc_tbl.cc
+@@ -96,7 +96,7 @@
+ typename map_t::iterator value_iterator=map_t::find(old_item_ptr->key());
+ if(value_iterator!=map_t::end())
+ {
+- erase(value_iterator);
++ this->erase(value_iterator);
+ retval=true;
+ }
+ return retval;
diff --git a/dev-util/cccc/files/cccc-3.1.4-unbundle-pccts.patch b/dev-util/cccc/files/cccc-3.1.4-unbundle-pccts.patch
new file mode 100644
index 000000000000..d5fed684df0f
--- /dev/null
+++ b/dev-util/cccc/files/cccc-3.1.4-unbundle-pccts.patch
@@ -0,0 +1,47 @@
+--- cccc/posixgcc.mak
++++ cccc/posixgcc.mak
+@@ -24,9 +24,11 @@
+
+ PATHSEP=/
+
++PCCTS_INC = /usr/include/pccts/
++
+ CCC=g++
+ LD=g++
+-CFLAGS=-c -I../pccts/h $(CFLAGS_DEBUG) -x c++
++CFLAGS=-c -I$(PCCTS_INC) $(CFLAGS_DEBUG) -x c++
+ C_OFLAG=-o
+ LDFLAGS=$(LDFLAGS_DEBUG)
+ LD_OFLAG=-o
+
+--- cccc/rules.mak
++++ cccc/rules.mak
+@@ -39,8 +39,8 @@
+
+ # locations and flags for antlr and dlg (don't change the flags unless you
+ # understand PCCTS)
+-ANTLR = $(PCCTS_BIN)$(PATHSEP)antlr
+-DLG = $(PCCTS_BIN)$(PATHSEP)dlg
++ANTLR = antlr
++DLG = dlg
+ # Flags for ANTLR:
+ # -CC = generate C++ output
+ # -k 2 = use at least 2 tokens of lookahead
+@@ -164,14 +164,14 @@
+ # to cover this is to add explicit rules for the three
+ # PCCTS support files which give rise to linkable object
+ # files.
+-AParser.$(OBJEXT): $(PCCTS_H)$(PATHSEP)AParser.cpp
+- $(CCC) $(CFLAGS) $(PCCTS_H)$(PATHSEP)AParser.cpp $(C_OFLAG)$*.$(OBJEXT)
++AParser.$(OBJEXT): $(PCCTS_INC)$(PATHSEP)AParser.cpp
++ $(CCC) $(CFLAGS) $(PCCTS_INC)$(PATHSEP)AParser.cpp $(C_OFLAG)$*.$(OBJEXT)
+
+-DLexerBase.$(OBJEXT): $(PCCTS_H)$(PATHSEP)DLexerBase.cpp
+- $(CCC) $(CFLAGS) $(PCCTS_H)$(PATHSEP)DLexerBase.cpp $(C_OFLAG)$*.$(OBJEXT)
++DLexerBase.$(OBJEXT): $(PCCTS_INC)$(PATHSEP)DLexerBase.cpp
++ $(CCC) $(CFLAGS) $(PCCTS_INC)$(PATHSEP)DLexerBase.cpp $(C_OFLAG)$*.$(OBJEXT)
+
+-ATokenBuffer.$(OBJEXT): $(PCCTS_H)$(PATHSEP)ATokenBuffer.cpp
+- $(CCC) $(CFLAGS) $(PCCTS_H)$(PATHSEP)ATokenBuffer.cpp $(C_OFLAG)$*.$(OBJEXT)
++ATokenBuffer.$(OBJEXT): $(PCCTS_INC)$(PATHSEP)ATokenBuffer.cpp
++ $(CCC) $(CFLAGS) $(PCCTS_INC)$(PATHSEP)ATokenBuffer.cpp $(C_OFLAG)$*.$(OBJEXT)
diff --git a/dev-util/cccc/metadata.xml b/dev-util/cccc/metadata.xml
new file mode 100644
index 000000000000..b2c5f531058e
--- /dev/null
+++ b/dev-util/cccc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cccc</remote-id>
+ <bugs-to>http://sourceforge.net/tracker/?group_id=7763</bugs-to>
+ </upstream>
+</pkgmetadata>