summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/bluej
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/bluej')
-rw-r--r--dev-util/bluej/Manifest4
-rw-r--r--dev-util/bluej/bluej-3.1.1.ebuild59
-rw-r--r--dev-util/bluej/files/bluej.wrapper6
-rw-r--r--dev-util/bluej/metadata.xml7
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-util/bluej/Manifest b/dev-util/bluej/Manifest
new file mode 100644
index 000000000000..c6951217965a
--- /dev/null
+++ b/dev-util/bluej/Manifest
@@ -0,0 +1,4 @@
+DIST BlueJ-source-311.zip 15564184 SHA256 a46df90291d1a7ae1d3088ea090def6b077d837c9d177c4d7582fe4ec6b26442 SHA512 60515f8564f0edf96ffba69ff43c199c024da12ac5601cba5f163c5682c9466717e2048593582ad2fe5d61988380e3fb9205825ec8967e99983c8a2a02f5144a WHIRLPOOL 156435663fef87052199d2aae8c4010b75f9ccb7c53ac5a7907d9e4c0346534d93011e0bf0f88303826c8d507974028664729f43c508893cff26b272206cfa0e
+DIST bluej-ref-manual.pdf 768751 SHA256 a6c514fcc79ffa1450c6313bae8b92ebe6c6939580cdf1a38e885a4cf71cffc3 SHA512 7f7e8cc2eab6402722eb8f94c878b506f595eee280cdfa85497d926cb06aa229defb0c8fbe5353dbbf6587e36a99ad5dae0a50fca21c1c80c88a92647d9b5319 WHIRLPOOL 476cc9058ecb4f79d9e4f3ccbec3a299f0f3deb357245bac0ab64e3bf0ce4e49f8aedfd5cbfe389b31c6d99e21491b6a002383bfa284eb0b9b4282545dbad6fe
+DIST bluej-testing-tutorial.pdf 269284 SHA256 07605ab6dd9743b6c971aaa932a3e8218057034af08d24ac90a09a74a5eb5599 SHA512 015da66cbf4940ca4bcab535023608a8497e7c6df1e06988393f8f0c7300a4521025474bf828e7889ff717e988968a2e973330758bf6dd570c057a837c78a9b5 WHIRLPOOL 472cbda358804a809ef61b8d1be947cba637e56068f3b0365f6ce808c0d076208b4b4430dfd6bb81eca987de407556e9bf83e019057f95320681a69ef2abe9b9
+DIST bluej-tutorial-2.0.1.pdf 1205655 SHA256 a6587a178ac7c071696884d9318aa33ade543898c5722caf61308acd77092db2 SHA512 410acbb75091d14b5ee7f5d56c01441a9611ed1f8b583c0301e1badf3d01bd2bb284da77d422c38ace283e7fe066b7975c772859697d25d6e9b334053d2f4833 WHIRLPOOL 27b1f934e2d08c261d32f385aa65ee826add4cb056257c6ab5e8c2e2b54a9f0fc884882bc4f611a1d87fe423706b8c4578b7c40060cceb46571924ee5d64b30d
diff --git a/dev-util/bluej/bluej-3.1.1.ebuild b/dev-util/bluej/bluej-3.1.1.ebuild
new file mode 100644
index 000000000000..9a01e99e5398
--- /dev/null
+++ b/dev-util/bluej/bluej-3.1.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source"
+EANT_BUILD_TARGET="ready-to-run"
+EANT_DOC_TARGET="doc-core"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DOC_PV="2.0.1"
+
+DESCRIPTION="An integrated Java environment for introductory teaching"
+HOMEPAGE="http://bluej.org/"
+SRC_URI="http://www.bluej.org/download/files/source/BlueJ-source-${PV//./}.zip
+doc? ( http://bluej.org/download/files/${PN}-ref-manual.pdf
+ http://bluej.org/tutorial/tutorial-${DOC_PV//.}.pdf -> ${PN}-tutorial-${DOC_PV}.pdf
+ http://bluej.org/tutorial/testing-tutorial.pdf -> ${PN}-testing-tutorial.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=virtual/jdk-1.5.0"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+java_prepare() {
+ sed -i \
+ -e "s:^build_java_home=.*$:build_java_home=$(java-config -O):" \
+ -e "/^bluej_home/d" \
+ build.properties || die
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r lib icons
+
+ # fix config location and set symlink
+ dodir /etc
+ mv "${D}"/{usr/share/${PN}/lib,etc}/${PN}.defs
+ dosym /{etc,usr/share/${PN}/lib}/${PN}.defs
+
+ use source && java-pkg_dosrc src/${PN}/*
+
+ insinto /usr/share/doc/${PF}
+ use examples && { doins -r examples
+ docompress -x /usr/share/doc/${P}/examples ; }
+ use doc && { doins "${DISTDIR}"/${PN}-*.pdf
+ dohtml -r doc/all/* ; }
+
+ newbin "${FILESDIR}"/${PN}.wrapper ${PN}
+
+ make_desktop_entry ${PN} Blue-J
+}
diff --git a/dev-util/bluej/files/bluej.wrapper b/dev-util/bluej/files/bluej.wrapper
new file mode 100644
index 000000000000..8d5fe5278092
--- /dev/null
+++ b/dev-util/bluej/files/bluej.wrapper
@@ -0,0 +1,6 @@
+#!/bin/sh
+APPBASE="/usr/share/bluej"
+JAVAPATH="$(java-config -O)"
+CP="$APPBASE/lib/bluej.jar:$JAVAPATH/lib/tools.jar"
+"$JAVAPATH/bin/java" -cp "$CP" bluej.Boot "$@"
+
diff --git a/dev-util/bluej/metadata.xml b/dev-util/bluej/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/dev-util/bluej/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>