summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-12-15 12:39:27 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-12-15 12:59:15 +0300
commitedc8f4d101689b487497bc8512e03feab03fc7f1 (patch)
tree9312364fd5166eb8676ba479f4f54c7df7723dcc /dev-tex/chktex
parentnet-analyzer/munin: drop ancient blocker (diff)
downloadgentoo-edc8f4d101689b487497bc8512e03feab03fc7f1.tar.gz
gentoo-edc8f4d101689b487497bc8512e03feab03fc7f1.tar.bz2
gentoo-edc8f4d101689b487497bc8512e03feab03fc7f1.zip
dev-tex/chktex: port to EAPI=7
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-tex/chktex')
-rw-r--r--dev-tex/chktex/chktex-1.7.6.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/dev-tex/chktex/chktex-1.7.6.ebuild b/dev-tex/chktex/chktex-1.7.6.ebuild
index 4f066f5c4caf..4481fd8c9e6c 100644
--- a/dev-tex/chktex/chktex-1.7.6.ebuild
+++ b/dev-tex/chktex/chktex-1.7.6.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-AUTOTOOLS_AUTORECONF=true
+EAPI=7
-inherit autotools-utils
+inherit autotools latex-package
DESCRIPTION="Checks latex source for common mistakes"
HOMEPAGE="http://www.nongnu.org/chktex/"
@@ -18,17 +17,19 @@ RESTRICT="!test? ( test )"
# Tests fail without pcre. Enable pcre by default and make tests depend on it.
REQUIRED_USE="test? ( pcre )"
-RDEPEND="virtual/latex-base
- dev-lang/perl
- pcre? ( dev-libs/libpcre )"
+RDEPEND="pcre? ( dev-libs/libpcre )"
+
DEPEND="${RDEPEND}
sys-apps/groff
dev-texlive/texlive-fontsrecommended
doc? ( dev-tex/latex2html )"
+BDEPEND="virtual/latex-base
+ dev-lang/perl:="
+
PATCHES=( "${FILESDIR}/${PN}-1.7.1-asneeded.patch"
"${FILESDIR}/tex-inputenc.patch" )
-DOCS=( NEWS )
+
AT_M4DIR="${S}/m4"
src_configure() {
@@ -38,21 +39,20 @@ src_configure() {
$(use_enable debug debug-info)
$(use_enable pcre)
)
- autotools-utils_src_configure
+ econf ${myconfargs[@]}
}
src_compile() {
- autotools-utils_src_compile
- autotools-utils_src_compile ChkTeX.dvi
- use doc && autotools-utils_src_compile html
+ default
+ emake ChkTeX.dvi
+ use doc && emake html
}
src_install() {
+ default
if use doc ; then
- HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/HTML/ChkTeX/")
- DOCS+=("${AUTOTOOLS_BUILD_DIR}/HTML/ChkTeX.tex")
+ dodoc HTML/ChkTeX.tex
fi
- DOCS+=("${AUTOTOOLS_BUILD_DIR}/ChkTeX.dvi")
- autotools-utils_src_install
+ dodoc ChkTeX.dvi NEWS
doman *.1
}