summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/tcl-mccp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/tcl-mccp')
-rw-r--r--dev-tcltk/tcl-mccp/Manifest1
-rw-r--r--dev-tcltk/tcl-mccp/files/tcl-mccp-0.6-flags.patch18
-rw-r--r--dev-tcltk/tcl-mccp/metadata.xml8
-rw-r--r--dev-tcltk/tcl-mccp/tcl-mccp-0.6.ebuild21
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-tcltk/tcl-mccp/Manifest b/dev-tcltk/tcl-mccp/Manifest
new file mode 100644
index 000000000000..1b7d413c8e4d
--- /dev/null
+++ b/dev-tcltk/tcl-mccp/Manifest
@@ -0,0 +1 @@
+DIST tcl-mccp-0.6.tar.gz 167446 SHA256 caf3fe21bc62a8a39e4360eb5ccd9100bdc2c9a04a0dbfd0f6aaea1862042b0c SHA512 d3f77b49454dc4f838b91d95146c71d6f8d46d293743b46b551e9217a92a9f6b03b26400cc21faf9bb22a0a0f92123b25f9b284453f756654e87b82201c395e6 WHIRLPOOL 60b6ebe684a3a2f7558815a8840ff243621968c380e8aa3bd965a4370a517a0d0d5565006c9b00c6cd0cb19782cf950ef2d53c81e20a10ca1172387e287b57d2
diff --git a/dev-tcltk/tcl-mccp/files/tcl-mccp-0.6-flags.patch b/dev-tcltk/tcl-mccp/files/tcl-mccp-0.6-flags.patch
new file mode 100644
index 000000000000..b3b563d3d7c1
--- /dev/null
+++ b/dev-tcltk/tcl-mccp/files/tcl-mccp-0.6-flags.patch
@@ -0,0 +1,18 @@
+ Makefile.in | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 956887d..4af7a06 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -91,8 +91,8 @@ lib_LTLIBRARIES = libtcl-mccp.la
+ libtcl_mccp_la_SOURCES = MCCP.c mccpDecompress.c
+ lib_DATA = pkgIndex.tcl
+
+-CFLAGS := -Wall -I $(TCL_PREFIX)/include -lz
+-LIBS := $(TCL_STUB_LIB_SPEC)
++CFLAGS += -Wall -I $(TCL_PREFIX)/include
++LIBS += $(TCL_STUB_LIB_SPEC) -lz
+
+ # FIXME: is this the right way to mofify libdir?
+ libdir = @libdir@/tcl-mccp
diff --git a/dev-tcltk/tcl-mccp/metadata.xml b/dev-tcltk/tcl-mccp/metadata.xml
new file mode 100644
index 000000000000..3be4732250a6
--- /dev/null
+++ b/dev-tcltk/tcl-mccp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tcltk</herd>
+ <upstream>
+ <remote-id type="sourceforge">tcl-mccp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tcltk/tcl-mccp/tcl-mccp-0.6.ebuild b/dev-tcltk/tcl-mccp/tcl-mccp-0.6.ebuild
new file mode 100644
index 000000000000..fa3ce61046c4
--- /dev/null
+++ b/dev-tcltk/tcl-mccp/tcl-mccp-0.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="mccp extension to TCL"
+HOMEPAGE="http://tcl-mccp.sf.net/"
+SRC_URI="mirror://sourceforge/tcl-mccp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-lang/tcl:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-flags.patch )