summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2025-02-01 07:19:22 +0100
committerHans de Graaff <graaff@gentoo.org>2025-02-01 07:27:08 +0100
commit14187bf32efac131953d7dca0d39af2923905d9b (patch)
tree6c5cf9865e81ab0d689434146d316a7df65f8b6d /dev-ruby
parentdev-ruby/dry-types: add 1.8.2 (diff)
downloadgentoo-14187bf32efac131953d7dca0d39af2923905d9b.tar.gz
gentoo-14187bf32efac131953d7dca0d39af2923905d9b.tar.bz2
gentoo-14187bf32efac131953d7dca0d39af2923905d9b.zip
dev-ruby/dry-struct: add 1.7.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/dry-struct/Manifest1
-rw-r--r--dev-ruby/dry-struct/dry-struct-1.7.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/dry-struct/Manifest b/dev-ruby/dry-struct/Manifest
index fab2f16fdd9a..29adbd9c24af 100644
--- a/dev-ruby/dry-struct/Manifest
+++ b/dev-ruby/dry-struct/Manifest
@@ -1,2 +1,3 @@
DIST dry-struct-1.6.0.tar.gz 37804 BLAKE2B c41a764cea576126ace4729dcc34ccd88c80f8751d8e9e11c825fc4caccd3a2cf5b7c92b129d2275cc8731f70ae98271462a359e8f6acf3c5ba2242513d20e6b SHA512 78258a74fd4b359142d42133df4f632dca7518959a15e42d544ee3b3e94ff5f2c7d14b2ed38609a125c788d092203d574d46f5a1030f9ec28738f76d24d7cdcc
DIST dry-struct-1.7.0.tar.gz 39963 BLAKE2B f484a9ae9cc828c81d79a37fdbf0054fa4d38468061d45ef36d84f96fb52bbb69068edc4fade477faecfb1161b9b0911bac9c00c3d280104e2a84f2f9ce56270 SHA512 14c40d01be5e5a9dcdfc385415d86128da78fd25d34161c32299d403ecc8dcf27bddeecc416fccce9be964de21dde418330c728a3fb9e7f3ae3767aea5d8dfd7
+DIST dry-struct-1.7.1.tar.gz 40099 BLAKE2B 4d353c43b4441afa62343d243e59e97146043f7decd5ea0c125a13af0a640ed35560a488269ef680c2828122b99fc3dce6075aa8fdddd5ec135e094756e9e5b6 SHA512 df615d8f67e24f88a8e2a3386950b02849276d62d5ca8ddf47395ccb6c61d6161608b2e707b970bed35fb3aa2561b72d48eb0d527f5dc4223a3a04357f8f5e75
diff --git a/dev-ruby/dry-struct/dry-struct-1.7.1.ebuild b/dev-ruby/dry-struct/dry-struct-1.7.1.ebuild
new file mode 100644
index 000000000000..847bb51b0dae
--- /dev/null
+++ b/dev-ruby/dry-struct/dry-struct-1.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="dry-struct.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Typed structs and value objects"
+
+HOMEPAGE="https://dry-rb.org/gems/dry-struct/"
+SRC_URI="https://github.com/dry-rb/dry-struct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/dry-core-1.1:1
+ >=dev-ruby/dry-types-1.8.2:1
+ >=dev-ruby/ice_nine-0.11:0
+ >=dev-ruby/zeitwerk-2.6:2
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/dry-monads
+ dev-ruby/dry-struct
+ dev-ruby/warning
+)"
+
+all_ruby_prepare() {
+ # Avoid broken spec, already fixed upstream.
+ sed -e '/with Test::User/ s/context/xcontext/' \
+ -e '/with Test::SuperUSer/ s/context/xcontext/' \
+ -i spec/extensions/pretty_print_spec.rb || die
+}