summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/weakling
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/weakling')
-rw-r--r--dev-ruby/weakling/Manifest1
-rw-r--r--dev-ruby/weakling/metadata.xml8
-rw-r--r--dev-ruby/weakling/weakling-0.0.4.ebuild45
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/weakling/Manifest b/dev-ruby/weakling/Manifest
new file mode 100644
index 000000000000..50cbfb205cf0
--- /dev/null
+++ b/dev-ruby/weakling/Manifest
@@ -0,0 +1 @@
+DIST weakling-0.0.4-java.gem 13312 SHA256 f1f6c45b34fa1d465c16a06d731a9fc159acc190ac4a44c915b84c0a8a761aa9 SHA512 1f8d836cca03f1fc23597bccab9db25191a3500213aed031401f692206ef5f92cab2bffc0e5032d8d1634b463ad6cbec4408267fd17896f086543c131cb5f6e0 WHIRLPOOL 8ef691a7649fff403f04b727905a053424d3ef8154a46cb1f43bde0948bf9520b1df9da2cd303c151bd7bf5665b9eb98c6d8202765d6a31af1f3a94cff3ba8ce
diff --git a/dev-ruby/weakling/metadata.xml b/dev-ruby/weakling/metadata.xml
new file mode 100644
index 000000000000..ff7d8161fe0b
--- /dev/null
+++ b/dev-ruby/weakling/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">headius/weakling</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/weakling/weakling-0.0.4.ebuild b/dev-ruby/weakling/weakling-0.0.4.ebuild
new file mode 100644
index 000000000000..7bf33c06262e
--- /dev/null
+++ b/dev-ruby/weakling/weakling-0.0.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# This package is specifically for JRuby.
+USE_RUBY="jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="HISTORY.txt README.txt"
+RUBY_FAKEGEM_SUFFIX="java"
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit java-pkg-2 java-pkg-simple ruby-fakegem
+
+DESCRIPTION="weakling: a collection of weakref utilities for Ruby"
+HOMEPAGE="http://github.com/headius/weakling"
+LICENSE="Apache-2.0"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE=""
+
+CDEPEND="dev-java/bytelist
+ dev-java/jruby"
+
+DEPEND+=" ${CDEPEND}
+ >=virtual/jdk-1.5"
+
+RDEPEND+=" ${CDEPEND}
+ >=virtual/jre-1.5"
+
+JAVA_GENTOO_CLASSPATH="bytelist jruby"
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+ ruby-ng_pkg_setup
+}
+
+each_ruby_compile() {
+ java-pkg-simple_src_compile
+ cp "${PN}.jar" "lib/refqueue.jar" || die
+}