summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2023-11-28 19:37:40 -0500
committerHans de Graaff <graaff@gentoo.org>2023-12-01 09:29:11 +0100
commit7b494f49a9dc40492d452f9f91634a5ee42d4584 (patch)
treed50a3ee0a1e6f5e46b89dd93616f69c1acc21da7 /dev-ruby/stringio
parentapp-emulation/wine-proton: update live further (diff)
downloadgentoo-7b494f49a9dc40492d452f9f91634a5ee42d4584.tar.gz
gentoo-7b494f49a9dc40492d452f9f91634a5ee42d4584.tar.bz2
gentoo-7b494f49a9dc40492d452f9f91634a5ee42d4584.zip
dev-ruby/stringio: correct test invocation
Bug: https://bugs.gentoo.org/912472 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/stringio')
-rw-r--r--dev-ruby/stringio/stringio-3.0.6.ebuild2
-rw-r--r--dev-ruby/stringio/stringio-3.0.7.ebuild2
-rw-r--r--dev-ruby/stringio/stringio-3.0.8.ebuild2
-rw-r--r--dev-ruby/stringio/stringio-3.1.0.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/dev-ruby/stringio/stringio-3.0.6.ebuild b/dev-ruby/stringio/stringio-3.0.6.ebuild
index db9c0bd6dc1d..5fba86219b99 100644
--- a/dev-ruby/stringio/stringio-3.0.6.ebuild
+++ b/dev-ruby/stringio/stringio-3.0.6.ebuild
@@ -26,5 +26,5 @@ all_ruby_prepare() {
}
each_ruby_test() {
- ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
}
diff --git a/dev-ruby/stringio/stringio-3.0.7.ebuild b/dev-ruby/stringio/stringio-3.0.7.ebuild
index 86568861b053..e818ea6895b8 100644
--- a/dev-ruby/stringio/stringio-3.0.7.ebuild
+++ b/dev-ruby/stringio/stringio-3.0.7.ebuild
@@ -26,5 +26,5 @@ all_ruby_prepare() {
}
each_ruby_test() {
- ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
}
diff --git a/dev-ruby/stringio/stringio-3.0.8.ebuild b/dev-ruby/stringio/stringio-3.0.8.ebuild
index 1fbf38918157..a61d8368f129 100644
--- a/dev-ruby/stringio/stringio-3.0.8.ebuild
+++ b/dev-ruby/stringio/stringio-3.0.8.ebuild
@@ -26,5 +26,5 @@ all_ruby_prepare() {
}
each_ruby_test() {
- ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
}
diff --git a/dev-ruby/stringio/stringio-3.1.0.ebuild b/dev-ruby/stringio/stringio-3.1.0.ebuild
index e9ef6cc8a7cf..645b3526510e 100644
--- a/dev-ruby/stringio/stringio-3.1.0.ebuild
+++ b/dev-ruby/stringio/stringio-3.1.0.ebuild
@@ -26,5 +26,5 @@ all_ruby_prepare() {
}
each_ruby_test() {
- ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
}