summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-07 09:28:22 +0100
committerSam James <sam@gentoo.org>2023-04-07 12:24:58 +0100
commitcf4e4995106cc2e248eb3c4bee873577b985f501 (patch)
tree3091f2ff5eaed6c736b15357b4e7ef8bf0e2b28b /dev-ruby/sprockets-rails
parentdev-ruby/sprockets: enable ruby32, fix rack dep (diff)
downloadgentoo-cf4e4995106cc2e248eb3c4bee873577b985f501.tar.gz
gentoo-cf4e4995106cc2e248eb3c4bee873577b985f501.tar.bz2
gentoo-cf4e4995106cc2e248eb3c4bee873577b985f501.zip
dev-ruby/sprockets-rails: enable ruby32
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/sprockets-rails')
-rw-r--r--dev-ruby/sprockets-rails/sprockets-rails-3.4.2-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/sprockets-rails/sprockets-rails-3.4.2-r2.ebuild b/dev-ruby/sprockets-rails/sprockets-rails-3.4.2-r2.ebuild
new file mode 100644
index 000000000000..242ef49f69eb
--- /dev/null
+++ b/dev-ruby/sprockets-rails/sprockets-rails-3.4.2-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Sprockets implementation for Rails 4.x (and beyond) Asset Pipeline"
+HOMEPAGE="https://github.com/rails/sprockets-rails"
+SRC_URI="https://github.com/rails/sprockets-rails/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/actionpack-5.2:*
+ >=dev-ruby/activesupport-5.2:*
+ >=dev-ruby/sprockets-3.0.0:*"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest:5.15
+ >=dev-ruby/railties-5.2:*
+ dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+
+ # Match activesupport
+ sed -i -e "1igem 'minitest', '< 5.16'" test/*.rb || die
+
+ # It looks like tests are order dependent
+ sed -i -e '/test_order/ s/:random/:alpha/' test/test_helper.rb || die
+}